SOLVED: PianoTeq not saving controller link

I am assigning a slider (external controller) to control the level within the PianoTeq VST. The little star that appears to the right of the name at the top of page, does not appear, (although this also happens in any other VST as well if the edit is “within” the VST itself) but I do a CTRL-S anyway. I also go into the file menu and do a save-as as well. BUT when the VST is re-loaded at another time, that controller link is not being saved…It does seem to work with other VSTs so I am wondering if it might simply be a problem with PianoTeq??

Can anyone else reproduce this?


Hi @pax-eterna

This is just Pianoteqs’s behaviour. In the Current MIDI Mapping drop down save your mappings as another name, and then you can choose “Attach to Current Preset” which apparently selects that mapping set with the parameter.

Note though I couldn’t get the attach bit to work - perhaps you can figure it out.


Thanks Brad…that gets it saved , but I’m yet to sort the other. When I do I will post just in case someone else has a problem :slight_smile:

Okay. in the end it is quite simple…isn’t it always haha!

So you do the “midi learn” thing, then you need to save this as a user MIDI set…using the drop down box and ALSO select the “Attach to current preset” which (afaics) needs to be a user preset, as the factory ones cannot be written over.

So now when I load that preset and then save the C3 rack, it re-loads as expected!