(Solved) - (not so) funny stuff with racks

something strange is happening here:

  • I have a rack in my setup called VoiceLiveRack
  • it is connected to the MIDI port attached to my VoiceLive
  • It filters MIDI data from my main keyboard, removes controllers and sends only the notes to VoiceLive
  • also, it contains a “state load” binding that sends a program change to VoiceLive, so that I can easily select a preset in my VoiceLive by selecting a rack state.

So far, this is working quite nicely. But recently, I reorganized my VoiceLive presets; after this, I opened my VoiceLive Rack and changed the program changes for each rack state, updated the state and saved the rack. So far, so good…

But in today’s rehearsal, I loaded my usual set list (containing the VoiceLive Rack in all songs), selected the first song, and even though the VoiceLive Rack was set to “Lead Vox”, my voice suddenly sounded pretty chipmunky - the rack had sent the OLD program change to the VoiceLive (where now some funny effects preset resides at this number).

I opened my VoiceLive Rack for editing, and lo and behold: the old program change was still displayed in the binding. But: after changing to some other state and back to “Lead Vox”, suddenly the NEW program change was active, and the correct preset was selected.

This happened in a number of songs today (pre-loaded setlist) - when I loaded a song, at first the old program change was sent, then, after I had changed the VL rack state to some other state and back, the correct new preset was selected. TBH, I’m pretty spooked - is my VoiceLive Rack possessed by the ghost of presets past???

@brad: do you have any explanation for this strange behavior?



Ugh - found the gremlin: Somehow the “controlled by song” tick box was set for the “target” property of the program change binding - not sure how this happened, but this explains a lot - if the target is modified by the song, then of course the “old” program change is still embedded in all my songs - that explains the ghosts.

Case closed :wink:




Glad you solved it Torsten…and it’s a good thing for the rest of us to check in our setups to avoid similar confusion!