SOLVED - Moved over to a new PC (Win10) and transferred over the VSTs and song files. I have VSTs that worked fine on one PC (also Win10) but won't show up on new one

I am trying to get some instrument VSTs (T-Force Alpha Plus and Odin2, among others) that I used on one PC running on my new laptop. I realize that they are in different folders than before, but most of the others were found and showed up just fine, even in the song workspace. I’m not sure what’s going or what’s really different from 1 PC to the other. They’re both Win10 and updated and everything. Cantabile just doesn’t see some of these instruments on this new PC.

TIA for any help.

Welcome to the forum!

How exactly did you transfer everything to the new PC?
Unless you made an exact copy of your hard drive, there are going to be several vsts that need to be properly installed to work. I made a transition last year, and it took awhile to get everything lined out. Many vsts are also linked to to the PC, whether thru license, format (like Kontakt, and UVI), or protection like iLok. Files linked to many vsts will have support in different areas of your hard drive. I had to re-install many things on my newer PC.



1 Like

I copied them over from the folder I had them saved to. Odin2 appears to require installation, but T-Force Alpha should be standalone. I had one plugin (Hyrbid) which seemed to require iLok but I simply just deleted it for now.

It seems like my issue is that these plugins don’t have any plugin ID and I have no clue why that is.

Even though T-Force Alpha is a standalone, doesn’t necessarily mean it’s all inclusive in one folder. Let me give you an example: Let’s say I have a vst named SuperVXCT. It puts it’s main files under the Steinberg folder, it’s VST dll is in C:/Program files/vstplugins. It also puts it’s it’s samples in C:/user/AppData/local/SuperVXCT/ files. The licensing file is in another mysterious file.

Just understand, this is done a lot, and when you install a program, it writes all these files. Pointing C3 to a VST dll is normal, but the supporting files are scattered throughout your hard drive, and the dll will not work without those support files.

That is why I said, many VSTs have to be re-installed. It is a P.I.T.A. but that’s what they do.

Well, it took quite a while for me to find the answer, but the problem was that these plugins required a certain MS redistributable that wasn’t installed on this new PC yet. I finally clued into that after reading the info ALLLLLL the way at the bottom of T-Force Alpha’s website download page (after where it says Please note:)

I should’ve figure this. It’s actually pretty common.

1 Like

As usual, Corky’s explanations are faultless. I’d add this:
is also used. I found VSTs support files, like .exe and .bin, into the documents… inattentive developers? :zipper_mouth_face:
Most of time, buying a PC with installed Windows, there is a default user named “user”. Brilliant, huh? So you need to create a username with the same name as in the old PC. If you do that, uninstall first all your programs (Cantabile, DAW, VSTs) then reinstall after you logon using the new username.
And, of course, the scattered dll issues is a neverending horror story.


All of the above about files. Also the Registry of Windows may store weird keys and parameters. And if you want to brick a Windows PC, just mess up the Registry. Often the Registry is what tells programs and the Windows OS where all the seemingly random file locations are. For some developers (ex. Microsoft) it is intentional to hide needed files.

Also, the proper C library will be needed. Even Cantabile relies on that.

1 Like

I’ll add to @Corky’s comment: plugins are essentially software, not data. Software will in most cases require installing, not simply copying a DLL file (even though that may work for some (mostly free) plugins.

An installation script will ensure that all necessary program and data files get installed to their respective places, registry entries are made, software prerequisites are installed (iLok, MS redistributables, etc.).

There is software that can be simply copied from one system to the other: that’s so-called portable software - and these programs are specifically designed (or configured) to be portable. Some plugins are actually portable, since they consist of only one DLL and don’t require anything beyond plain vanilla Windows environment, but the majority of plugins is more complex.

TL;DR: don’t just copy your plugin folder - do a full install of all your plugins to be on the safe side.



1 Like

Cannot fault what both Corky and Torsten have told you. Even though Cantabile will only see the DLL, and some plugins may all be packed n a single DLL, there are very few like that these days. The DLL will be hunting for other software, user interface components and other data scattered across your system, bearing in mind that no two vendors will do the same thing in terms of structure. Safest to do a clean install…

1 Like

My Cantabile install was fresh. And actually, all I needed was that MS VC++ redistributable package installed (acquired here: and everything was fine after that was installed. So afterwards, my old Cantabile songs were able to find and run the old plugins with no problems as long as they were in a folder that I designated in the settings.

The VC redistributable is actually a very common dependency for many Windows programs and applications. Very few people have probably run into this issue right off the bat like I did because the package was probably installed along with some other software (DAWs or games or something). I actually have ran into this issue on a fresh Windows install before.

I agree that some of VSTs required reinstallation, such as Odin2. But even after I reinstalled it, it still wasn’t recognized and running. And T-Force Alpha is a standalone VST that didn’t require any installation steps, just unzip into a VST folder. It wasn’t until after I installed the redistributable that these VSTs were being recognized by Cantabile.

As it pertains to my original issue, I was able to resolve it by installing the redistributable package I mentioned earlier. Maybe someday this thread will help anyone that runs into the same issue as I have.