SOLVED: Media Player set play head by clicking gone?

Not sure if it’s me or something has changed in 4150 - I used to be able to set the play head in the media player by clicking somewhere in the timeline. This doesn’t seem to work anymore. Not sure if this is a side-effect of 4150 or if I am doing something wrong…

Also, when I drag the play head, it turns blue instead of red and the timeline shows as grey instead of blue-ish - does this simply mean that selection has changed and the play head is now selected? @brad - did you change something on the media player in 4150?



If you click on the file graphics at the point you want it locates but not when you click the timeline itself on my rig using 4150.

Hmm, that’s the funky thing - clicking on the waveform graphic doesn’t locate for me. Is there any setting that might affect this?

Hi @Torsten,

Nothing was changed in this area. It should work like this:

  1. If focus is not in the timeline, clicking in it will move focus there without moving the play position.
  2. Once focused, moving the mouse around in the timeline will show a very light vertical orange indicator at the mouse position.
  3. Clicking on the waveform area should move the play position to that point.
  4. Clicking the play head indicator moves focus to the play head turning it blue and the wave form grey (and it can then be moved with arrow keys).

It sounds like 3 is broken for you?

The only other thing I can think that might affect this is the move to .NET 6 in 4150 but that seems unlikely. There’s no setting for this. It’s working correctly here on my test machine.


Exactly - whenever I click in the focused timeline, the cursor changes to a “text selection” cursor; when keeping the mouse button down, this makes the timeline zoom in to waveform level.
Since clicking immediately changes to the selection cursor, I suspect that my Cantabile installation can’t distinguish correctly between “click” and “drag” - maybe that helps finding out what’s behind this?

Very weird.

What you’ve described sounds like the behaviour when the Z key is held to zoom in on a range. You don’t have a stuck Z key by any chance? Or perhaps press it a couple of times in case somewhere a Z key up key event was missed?

Does it still happen after restarting Cantabile?

Failing the above, could you roll back to 4140 and:

  1. Confirm the same behaviour doesn’t happen.
  2. Confirm whether holding the Z key reproduces the behaviour you’re seeing in 4150.


1 Like

OK, did some more testing with both 4140 and 4150, with all kinds of funky results.

Considering all parameters involved, I finally thought of disconnecting my remote control software (that I generally use to work with my Cantabile PCs) and connecting a hardware keyboard to my Cantabile PC. Suddenly, things seemed to work nicely.

With some more experimentation, I found that I needed to re-configure RustDesk’s keyboard mode; now it seems to behave nicely with my Cantabile PC without “sticking” the zoom key.

BTW: I need to use the “Y” key on my German keyboard to activate the “Z” modifier - looks like the keyboard hook used for this modifier isn’t localized - and I can’t set this in the keyboard shortcut settings (all other timeline commands can be customized, but not the “Zoom” hold key). Maybe something to look at when you have time - alternatively, you might want to update the guides page accordingly…

Problem solved - thanx for pointing me towards the “stuck Z key” - that helped me identify the culprit…



1 Like

Hey @Torsten,

Phew… glad that one’s sorted.

Regarding Z and localization you’re right and I noticed that this morning when I was reviewing the code trying to figure out what might be happening on your machine. I’ll see if I can get it fixed.

(technical: it’s not available as a key binding because its a simple “is key pressed” check rather than listening for a key binding).