(SOLVED) M-Audio Keystation and Cantabile - no sound with THIS keyboard (works with another)

So I am demo’ing Cantabile right now. It works perfectly with my old Technics Piano that I use an USB midi cable (MIO) with and Halion plugins. But…

I really need it to work with my M-Audio Keystation 88 (MIDI controller). And I cannot make it happen. I should mention this Keyboard works just fine with Cubase and the same plugins. FWIW, it ‘is’ receiving the signals because I’ve looked at the input log but not the output. And I get sound when I map to the on screen keyboard with the same plugins. And like I said, it works perfectly with the Technics/MIO setup.

The only thing I can think of is that the Keystation uses a USB MIDI in/out instead of the usual MIDI pin cable in/out setup and that is causing my issues. It does have a MIDI (pin) cable connection on it but it’s an in/out combined, also. I don’t currently have a cable like that to test it and am feeling like this would still be the same issue because it’s a combination in/out, too.

I really am a noob when it comes to understanding the MIDI mapping. I get that notes, volumes, etc. are all mapped to numerical values. I also understand there are channels. What I’m not totally clear on is the in/out channel maps that Cantabile offers and haven’t been able to find a great explanation to see if changing any of this would help. Is there something else I need to do with mapping because of this setup?

Any advice would be greatly appreciated. I need a reliable program for playing live. I’m using Cubase for recording and it’s just not what I need for live performances.

Welcome to the forum Amy!

Have you looked at the excellent videos and literature in setting up your controller? Cantabile has a learning curve. Once you understand setting up midi ports and audio ports, it becomes much more intuitive. It is much easier for you to study the mechanics in the guides, than a repeated, long detailed explanation here. Below is where you can get the info you need. Once you’ve got the basics, it’s easier to move on. I usually gig and rehearse 6 days a week, and Cantabile has been my workhorse for over 6 years. It is the standard for live performance IMHO. Once you understand the basics and hit a snag, come back for more help.




As you had to configure your controller in Cubase, it also has to be configured in Cantabile. The usb acts the same as midi cable, but usb will also power most modern controllers. Once you plug in the usb in your computer, Cantabile should recognize it, then you configure it per instructions in the guides. Hope that clears up a few things.

1 Like

Thanks. I’m combing through the guides you posted now.

I really didn’t have to do any setup for Cubase. It was pretty much plug and play once I directed it to the correct plugins folder. I even figured out how to create racks in Cantabile with my digital piano which is pretty cool. So I know it works.

What I cannot seem to figure out is why I can’t get sound from that other keyboard. Like I said, I’m guessing it has to do with the MIDI out because I am not seeing that sending anything in the logs. Hoping something I read/watch clears up how to fix that. Troubleshooting this is a little overwhelming.

I also want to mention that Cantabile is working perfectly with my digital piano. Same laptop. Same plugins. Nothing has changed except the MIDI hardware connected to the laptop.

And the M-Audio hardware is operational in Cubase. It also works in Halion Sonic SE. So it’s definitely not a dysfunction there.

My initial suspicion was that Cantabile didn’t like the fact I switched out the external MIDI controller on it and so it’s just not cooperating. I haven’t tried an uninstall/reinstall yet to determine that. Or as I mentioned previously, it doesn’t like the USB cable that my M-Audio uses. Beyond that, I start thinking about it having non standard MIDI output needs and my M-Audio manual doesn’t talk about any of that.

What I am getting in your post, is the M-Audio controller works well in Cantabile, and that your Digital Piano is not working. So, the Digital only has a traditional midi output, but no usb out? If so, how are you using the Digital with standard midi cable? Are you using an audio interface with midi pin cable?

Another thing I need to tell you…in Windows, ALWAYS use the same usb port with the same controller. It will not let you switch ports, and has been a problem forever.


No, it’s the opposite problem. My old digital piano (really old - Technics) is working fabulously using an iConnectivity Mio USB to MIDI din cable. I installed Cantabile, set it up to point to the right places, audio outputs, MIDI inputs/outputs and boom. It was plug and play really.

I took the same laptop to my rehearsal space where my M-Audio controller resides and tried using it and nothing. As I am reading more, it may be related to the Keyboard’s weird way of reporting itself to the software. It does list 2 separate MIDI ports for itself. I saw another post in this forum where someone was having a different problem but it sounds related.

That is strange, because my M-Audio Keystation 88 works well. Hopefully, I am not being repetitive, but on the 88, you are only using usb cable, and not the iConnectivity?

Yeah, I literally just took the laptop, plugged in the usb cable that I always use with the M-audio keyboard and it just didn’t work even after going into the MIDI setup. I might just do a reinstall for a sanity check. Maybe something flaked out because of the other MIDI cable I use at home when I first installed and set it up on my digital piano.

I suggest you go to M-Audio and download the newest driver for your 88. That many times solves the problem. Drivers sometimes become corrupt, and they need to be reinstalled. A reinstall of Cantabile could also help. Also, usb cables can fail. After having those problems in the past, I went with a heavier cable.
I have a post in the forum somewhere about usb cables. If I find it, I will post it here.

1 Like

Here it is:

Dang, didn’t even think about a driver issue. That might solve another unrelated problem I’ve run into at times with it flaking in Cubase (sticking signals). Thank you!!!

Sigh…they have no drivers available for it. That sucks.

I’m not sure I understand the issue, but you have mentioned MIDI Out a couple of times. Are you sending midi out to the M-Audio Keystation 88? I don’t think it has an internal sound engine like your Technics Piano.
Assuming you have the midi port configured for your Keystation (Tools/Options/Midi Ports), then you should be able to use the Midi Monitor in Cantabile to see if midi messages are being received in Cantabile.
Then the next step would be to send that input to a plugin.
Cheers - David

1 Like


According to M-Audio, Keystation 88 II & MK3 are USB Class Compliant and do not need Windows Drivers (you didn’t state that you were using Windows, just my guess).

Also, you’ve stated “MIDI Cable” and “USB Cable”. I assume you’re connecting to the laptop via USB, correct?

I occasionally have trouble with our controllers (Roland “A-49”, Nektar “GX49” & Edirol “PCR-800”) and have to perform a “Factory Reset” to sort things out. Here is M-Audio’s procedure for the “Keystation 88”:

Factory Reset

  1. Power off Keystation.
  2. Hold down the buttons “+” and “-” simultaneously, until step 4.
  3. Power on Keystation.
  4. Release the buttons.
    The Keyboard is now back to the factory default settings.

Maybe that will do the trick for you.


1 Like

Hey Amy,

Cantabile is different to Cubase and other DAWs in that it has an additional layer of abstraction for MIDI ports: you have logical MIDI ports that you use within Cantabile, and physical MIDI ports (provided by the Windows operating system) that you connect to these logical ports. This is what the MIDI port settings are about:

When you connect your Keystation via USB, it will create its own MIDI port (different to the MIO - don’t know what the name for this is, but might be “Keystation…” :wink: ), so you need to be sure that the tick box for this specific MIDI port is set in the “Assignments” list for the “Main Keyboard” input port, as well as the tick box for the MIO interface. Now your “Main Keyboard” input will receive data both from the MIO and from the Keystation - depending which one is plugged in.

Once you’ve plugged in the Keystation via USB, the “Main Keyboard” MIDI port in Cantabile should correctly get the data from the “Keystation…” system MIDI port. To check this after you’ve made the settings above, right-click the “Input ports” source and select “MIDI Monitor → Main Keyboard”:

A new window will open that displays MIDI messages received from your “Main Keyboard” port - now you can see if any notes are displayed when you play your Keystation.

If this isn’t working, can you please share a screen shot of your “Midi Ports” settings for the “Main Keyboard” input port?



1 Like

Thank you so much. The factory reset fixed the issue!!!

1 Like

My pleasure! Merry Christmas!