SOLVED Anomaly in Background Rack Bindings in 3160 build

Hi, My requirement is a button to advance to next Song State. I have a Global Rack Binding tied to a “Next State” button on my Novation controller. The Binding advances to the next State correctly the first time it is fired; it never works again unless I delete it and re-add it.

I’ve used Bome MT to capture MIDI I/O. For test purposes, I’ve disabled all other Background Rack Bindings. The bottom Binding shows Main Keyboard (tied to Bome MT virtual out) looking for Cntl 44 on Ch 16 (hex BF 2C 7F) to advance to Next State.

Moving to a test song, with 4 Song States, starting at State 1, all other Bindings disabled, MT log is empty…

Final screenshot shows two presses of the “Next” button on the Novation. The first works. After that it never works again.

MT log shows first press successfully captured by the Binding and fires Triggers to setup for first Verse. But after a second press, one can see the 3 events in the MT log (In/Out of BF 2C 7F), but the State isn’t advanced and the Triggers don’t fire.

Again, deleting and re-adding the Background Rack Binding makes it work 1 time. For a workaround I used 3 Song State Bindings (you can see disabled) on each State.

Windows 10, ProSonus 1818VSL AudioBox; Novation SL ZeRO controller; C3 build 3160. Bome MIDI Translator.

Hi Richard,

That definitely sounds like a bug. Quick question does the binding’s routing mode (right click menu) have any affect? What do you have it set to?

I’ll take a closer look at this in the morning (in the middle of some other work right now).


Thanks, @brad. I’ll do some testing with Binding Modes. They are set to whatever the default is–I haven’t investigated that feature at all. And, I have the log.txt where I captured this if you’re interested. It looks normal for the first button push, then the second you see the button push, but no change of state, etc. For now, I have to go get on an airplane. Work calls!

OK - if you haven’t changed them from the default it’s probably not the problem - but possibly. Let me know how you go.

Either way I’m probably going to need to figure out how to reproduce it. Can you email me a copy of your setlist, songs and racks?


SOLVED: @brad. Thanks for the catch of the rookie mistake. As you suspected, the button was sending a “0” on release. Changing the control to Control (No Edge Button) fixed the problem. The button now correctly advances the State.