Software Keeps Adding Keyboards

I just started trying to set up my songs in the software. I am using audio only - no MIDI. No keyboards.
It seems if I go to the Tools → Options menu item, then close that dialog and come back, the software adds keyboards to input ports routing [see picture]

Why is it doing this? I didn’t ask for keyboards or accidentally click on the input port routing.

Hey Alex,

Go to Options>MIDI Ports and uncheck the unwanted MIDI Ports. This will rid you of unwanted automatic midi routing.