Sforzando Load Error


#1

I just started playing with Sforzando, and I have been able to run it stand-alone, but I get the following error when trying to add it to a linked rack within C3.

“Failed to load plugin 'C:\Program Files\Plogue\sforzando\VST\sforzando VST_x64.dll” - plugin failed to initialize [error code 13209)

Here is the log:
00126822 13711 [11580:2]: VST Plugin- sforzando VST_x64 (0x0000000205CA3ED0) - Loading C:\Program Files\Plogue\sforzando\VST\sforzando VST_x64.dll (platform: 0002)
00126826 4 ! [11580:0]: VST Plugin- sforzando VST_x64 (0x0000000205CA3ED0) - failed to load library (error code: 1114)

Any thoughts?

Thanks,
Rick


#2

Hey Rick … Will it add as a plugin still? It might be some kind of path problem with the sample library.


#3

That error code (1114) means “the dll failed during its initialization”. So my guess would be something about the way the plugin is installed.

I just downloaded version 1.952 of Sforzando here and it seems to work fine.

You didn’t by any chance install both the 32 and 64-bit editions to the same folder did you? That would probably be bad. Also, I installed to C:\VstPlugins32 and C:\VstPlugins64… perhaps there’s an issue with installation to the “Program Files” folder?

Also, does it work in other hosts?

Brad


#4

The path shown in the error was correct… aka… the file is there. Or shall I say… was there.

I have not tried it on another host, and I only installed the standalone and 64 Bit VST. I un-installed it last night and cleaned all traces from the registry. I can’t look at it today, but I’ll try installing it to a different directory.

It just seems odd that other VSTs initialize from the %\Program Files directory on my disks.

Thanks for the info!

Rick


#5

Well I am at wit’s end… as the saying goes. After wiping everything related to the program, I reinstalled it. I only installed the standalone and the 64Bit VST2. I placed the VST in a folder… D:\VST64. C3 sees it, but I still get the load error. I am running C3 3590 on an up to date Win10 system.

And… the standalone works fine.

Anyone else have any ideas?

Thanks!

Rick


#6

Just a speculation, but don’t you need to tell the instrument where the samples exist? I don’t think they exist in the same folder as the .dll plugin. The standalone likely finds them in its same folder in Program Files. Could that be the culprit?

Terry


#7

Does it work in other VST hosts or is this just a problem in Cantabile?


#8

Terry,

I’m not sure how I could fix this. The error pops up as I try to add the plugin to a new embedded rack.

Rick


#9

Brad,

C3 is the only host I use. Is there something free you could recommend as a test?

I’m going to see if I can get my older Win7 box fired up tomorrow. I’ll give that a whirl.

Rick


#10

You could try VstHost.


#11

Brad,

Sforzando loads fine in VSTHost.

The dll is in C3’s path, and it shows “Sforzando VST x64” on the plugin list.

If I use my “default” set list, I get the same error if I just try to add the plugin to a new song, or to a new embedded rack.

If I create a new set list, and restart C3… it loads fine.

Breadcrumb?

Thanks!

Rick


#12

Hrm… That’s weird. I wonder if this is conflict with another plugin in your set list. What happens if you:

  1. Load your default set list
  2. Turn off set list preload
  3. Create a new song
  4. Try to load the plugin.

Assuming the above works, try the same procedure but this time leave set list preloading turned on. If that fails it’s almost certainly a plugin conflict. From there I’d try to narrow it down by divide and conquer, removing half the songs from your set list at a time until you narrow it down.

Brad


#13

Brad,

Thanks for the advice. I copied my current set list, deleting anything that I was not currently using, and then I could get sforzando to load. Interestingly enough… I still got an error when I went to save a rack.

Error

So… I opted to create another new set list, load sforzando in an embedded rack first, and then add songs to the set list in twos and threes… testing along the way.

I’m not sure if I will ever know which piece of the pie was causing the issue, but it seems to be working now.

Thanks again to Brad, Terry, and Dave for the advice!

Rick