Set media player to start on next state load?


#1

Is it possible to set a media player so that it starts automatically when a new state is loaded?


#2

Hey Lee,

this binding in your song will do it, you have to pick the correct media player when you make it.

Dave


#3

Very helpful. Thank you. One more question.

I have recorded several different pad drones for various states, each recording is set to loop continuously until the next state change. I’ve noticed that there is an audible pop each time the loop begins and ends. Is there a way to record/play wav loops so that these pops don’t occur?


#4

Hi Lee,

I thought a little extra info on state on load binding use. When Song first loads it treats that as state 1 therefore the binding I showed you would fire. To be more precise about how it fires check the ‘enable’ behavior box for the binding. Then on the first state (song load) disable the binding

then on the state where you want it to fire enable it.

On the loops, could you post one to examine. If I understand correctly the loop itself has the pop? Or does it pop when you change states?

Dave


#5

It seems to be the loop itself, not the state change which is the source of the pop. looks like I can’t upload audio files…


#6

can you put in a zip file? It will upload


#7

Maybe I’m doing something wrong. I zipped it using 7-zip (.7z extension). It will not allow upload.


#8

HERE’S a link to a SoundCloud file. Of course it doesn’t loop so the pops aren’t as noticeable


#9

It allows only .zip but 7 zip app makes those too check the context menu and it’s there


#10

Recording 0316.zip (824.3 KB)


#11

I can tell from the view of it why you have the pop. The beginning of the loop has the attack of the initial key press and it gets repeated each time it loops. Normally in looping you would have that attack play once and make the loop point after that in the area of the sample where it has settled into a pad. I will look at the file and see if i can devise something from it or maybe you can do it as well.

Dave


#12

I thought that perhaps if I restricted the play range of the file (trimming the beginning and ending), it would get rid of the pop, but I’m still getting a pop at the end of the range as it recycles back at the beginning. Actually, I think that’s where the pop has been all along (at the end only). Is this just an artifact of the loop procedure? It’s really not a big deal if there’s not a fix. I don’t think that pop will be noticed by anyone other than myself


#13

Lee, I can hear a disctint pop at the end. I think if you added a subtle fade out (of just a fraction of a second) it might sound better. That’s what I have done with your recording. Could you try it out in a loop to see if it’s any better?

Recording 0316-edit.zip (969.9 KB)


#14

thanks, but the pop seems as noticeable as before when looping.


#15

there’s a few things about tis as a loop file that could be improved. One is when you make the loops convert the stereo to mono before making a loop. Second is when making the loop look for the “Zero crossover points” to set the lengths so they have little or no click.

lee return loop.zip (524.7 KB)

try this if it’s better i’ll show you what i did

Dave


#16

Thanks Dave. I’ll try the file. Regarding your suggestions, to convert to a Mono recording, would I go Media Player- edit Audio Ports- and the create and select a Mono out?

What are zero crossover points?


#17

I think the shortest and best way there Lee is for me to hand you over to the good folks at Audacity. They have a great tut on making loops and their app is very versatile for converting stereo to mono auto creation of zero crossing points etc… very feature rich app. Here is the link for the Loop making.

http://manual.audacityteam.org/man/tutorial_looping.html

really good info there

Dave


#18

Thank you Dave. Very good information to have. I’m sure there’s a comparable information for Reaper. I’ll check this out.


#19

Hey Dave, I’ve revisited this post as I have a song with a Intro state which I want to auto-trigger the media player when the state loads. I followed your suggestion to enable the binding for just the desired state. I have a “dummy” state (state 0) which I don’t want to trigger media when the song is loaded, and an Intro state #1 where I do want the media player triggered. Problem is that in Bindings view if I select Dummy state and uncheck Enable under State Behavior-Bindings, then click on state 1 (Intro), check “enabled”, then go back and reselect state 0, this binding is now enabled. In other words a binding change I make can’t be selectively apply to a state, it seems to affect all of them.


#20

Hi Lee,

It sounds like your states are locked or the “Enable” state behaviors for the bindings are not checked. If locked unlock them and re do your states and enable switches until they switch properly and/or check the state behaviors for the bindings. Lock states when done if desired or if you even use locks.

Dave