Scaler 2.8.x freezes Cantabile

Tags: #<Tag:0x00007f97895a9ec0>

I’ve been using Cantabile successfully with Plugin Boutiques’ Scaler 2 for some time

However, after the update to 2.8.0 / 2.8.1 using the operation to save the ‘state’ (so you can recreate a given snapshot) freezes Cantabile.

This behaviour doesn’t happen within other hosts (Live 11, for example) so it’s some incompatibility between the later version of Scaler and Cantabile.

Are there any other users with this combination ? If so, have you experienced this issue ?

1 Like

Yes, I have scaler.
I to updated to 2.8 and had exactly the same issue as you described and worse.

Scaler 2.8 was a pig on resources. took a far to long to load and far to long to switch
between various modes. scaler did seize the PC up with every function I wanted to perform.
I emailed PB to inform then of this. I never heard back.
I downgraded to 2.7 and the problem was gone/fixed.

It’s obvious that it’s something in the 2.80 update which clashes with Cantabile. The Cantabile exe didn’t change in that period…

I’ve posted it on the Scaler Forum as a bug, and will let you know if I get any meaningful response.

Cantabile didn’t seem to write a crash file, so no diagnostics to hand.
What is interesting is that you see a different manifestation to me, in that it only involves the ‘state save’ with me, whereas you are getting other failures. Also, it’s still fairly responsive, but that maybe because I have quite a big machine
i9-990 / 32Gb mem / 6 Tb storage with Samsung Evo 970 M2 SSD

I use Cantabile because it’s quick and easy to set things up and chain VSTs’ together. My main DAW is Live 11, where it’s more tedious just to play around.

1 Like

My system, i7 something black series “K” 3.5ghz, I cant remember at the moment
16gb, is not quite as big as your system however still has enough oomf to run
multiple vsts I have on it, yet unable to run scaler 2.8 on its own.
I’m interested to know if any thing comes of your forum post, your the first I came
across to have a similar issue with scaler.

I’ve just tried Scalar 2.8.1 in Cantabile - I have never tried it before as I normally only use it in Cubase.

I cannot see any performance issues, it is only using a few per cent of the audio cycle, and in Windows Task Manager, performance is very light

Can you provide a set of steps that causes your problem to see if I can replicate it?

Load up Scaler. Drag a song into section A, then copy that into section C, so

Now go to the top left Scaler iconstate and click to bring up the menu, and then ‘Export State’
this now freezes at the folder directory

The only way out is to terminate the process It works ok in Live and Bandlab… This has happened only after version 2.8.0 of Scaler, so it is some interaction with that change and Cantabile which doesn’t fail in other environments.

Running Scaler 2.8.1 vst3 version. Machine is Windows 10 Pro / i9-9900 / clocked to 4.9GHz / 32Gb / Samsung EVO 980 on M2. I don’t have any of the performance issues Laura reported, but there again the box is pretty ballsy.

Any ideas gratefully received. For sketching things out, Cantabile is 4+ x more efficient than using my normal DAW, Live 11.

Added 20:24 I’ve just discovered it won’t save Chord Sets either, which is a bit more problematical. I’m exploring …

I have never been a deep user of Scaler, so took me a little while to get there, but I can confirm that it gives me the same problem in Cantabile 4063. Click that save button and it becomes unresponsive and you need to kill it via Task Manager.

It is fine in Cubase 12, latest version.

It not only freezes for ‘State saves’, but when trying to save chord sets, so it’s a general file access problem.

I’ll report this on the Scaler board.

Update on this issue :

I reported a problem with Scaler 2 ( ) in Cantabile. After further testing I can confirm that both VST3 and VST2 plugins fail. However, these both work fine in Nanohost, Cakewalk, and others, so it is specifically a Scaler + Cantabile issue.

The problem is that any attempt to save or import data causes the UI to freeze in the file selector window; it is necessary then to kill the task. Nothing was logged in the cantabile console.
If anyone c an suggest where such a clash might reside, that would be very helpful.

Scaler 2.8.1 / Cantabile 4.0 4056
Windows 10 Pro i9-9900 / 32Gb / Evo 970 M2 SSD

Hi Laura

This issue has now been accepted by the Scaler devs as a bug, and will be fixed in the next minor release. Hopefully this wont be too long.

Meanwhile, I’ll just drag stuff into Live and back until I’m ready to drop it into Live for finishing.


Thanks for the tip, I didn’t see this reply until now.