Route Enable/Disable Issue [Build 4139]

Tags: #<Tag:0x00007f9784d53b08>

Not sure if this is an actual bug or if I have some kind of conflicting assignment I can’t find.
I have a controller set up to switch four routes on and off, currently using the onscreen keyboard for testing. The check boxes switch correctly, but don’t seem to be functionally switching.
Here is the initial set up:

And the bindings:

After moving the controller I get this:

The check boxes have switched correctly, but the 3rd and 4th routes are grayed out and disabled.
Then moving the controller back, everything is reversed:

I do have a second controller from a different source mapped the same way (for remote automation), but disabling them didn’t change the behavior. I tried unchecking all of the State Behavior boxes, adding delays, pausing loading operations (and not), but nothing seems to affect it. Clicking the checkboxes updates the condition of the other routes - so if I click the X for the String Route, the Organ and Bells routes will switch to being grayed out and are actually disabled. If I ride the controller between 64 and 65, it works correctly, but not if I move it faster and those exact values get skipped. I tried using >=65 instead of >64, and deleting and remaking both the routes and the bindings. No luck. The only difference I can figure out between the first two (which work correctly) and the last two is that the first two have the same target. Other than that I can’t figure out anything that makes them different.

Hi Sammy,

I set up the same scenario in 4139 and it worked fine but I wasn’t dealing with Kontakt, Ripchord or Zenology. Have you tried the same scenario with different plugins?

routes at < 64

routes at > 64