Revert rack crash


#1

I’m trying to integrate VB3 II in my setup again.
When I edit the VB3 II - rack and than do “revert rack” I always get an error message “active view wip collection not empty” followed by a crash of Cantabile3 when closing the rack.

Otherwise it works fine when playing, switching songs/song states.

I’m on version 3595 of Cantabile3 (Win 10 home).
The rack contains VB3 II, Klanghelm SDRR2, FuseAudio F-59, Meldaproductions MRotary, PSP FetPressor, Loudmax.


#2

Hi @ukm,

Can you email me a copy of the rack and I’ll look into it.

Brad


#3

Hi Brad;
thanks for quick reply. I just sent you the rack and the log file.
Normally this is not a big problem since I do not edit a rack during a gig.
If I remember right I had this behavior occassionally with earlier versions too when reverting a song or a rack.

In addition: Until now I didn’t have to use my backup laptop live. Cantabile3 always worked fine and it still is much fun to use it.


#4

OK, I enabled “Flush tail sounds on suspend” for the VB3 II and had no crashes until now when reverting the rack.


#5

That’s pretty bazaar - I wouldn’t have expected that. Please let me know if the problem recurs.


#6

Yes, seems a bit too easy - as long as it works … .
I did some experimenting before (deleted all other VSTs in the rack; deleted rack states/song states; deleted all bindings: built a new rack a. s o.).
Probably my technical understanding is not deep enough to point out the right direction from the error message but I read: “… collection not empty” and thought it must have something to do with memory when the plugin is shut down.
BTW: The behavior of the plugins regarding pseudo presets is different too. Some show the whole bank as internally available and others show only the pseudo presets I manually created inside the pseudo presets bank.

I think next week I have some more time for testing.


#7

No, that’s an internal error message from Cantabile’s list view component that suggests an update the list went awry. I’m keen to find out how to reproduce this so if you can make it happen again, please let me know.


#8

My hope for “solved” was too early - had some crashes with the same error message. Not many but I can’t track it down to a specific workflow.
It doesn’t seem to be related to VB3 II alone (I changed the title above).
I’ll have an eye on this and report back when I get an idea.


#9

Hi @ukm,

As mentioned, very keen to get this fixed. If you can find a reproducible scenario please send through the details.

Brad