[Request] Allow Tempo Fractions / Decimals e.g. 120.5 BPM

suggestion
Tags: #<Tag:0x00007f52be528718>

#1

Hi @brad - I’m wondering if it’s possible to allow fractions/decimals within BPM. I have a whole heap of tracks that I have been provided which were originally recorded with a dodgy Drum machine and have funny tempos e.g. 133.7 (being a common one). Ideally I’d like to use the Cantabile tempo but it won’t allow non-whole numbers. I can work around this by importing a MIDI file with the tempo but this feels clunky to me and the display still shows a rounded version of the BPM.

Is this something simple to implement? Would there be any issues with this?


#2

Hi @Hunter_Barr

To be honest I’m not sure off hand how much work this would be - I’ve logged it for now and will have a look at it when I get time.

Brad


#3

In the meantime, can you just load some other DAW (Sonar, say) that does fractional tempos and slave to that??


#4

Thanks @brad. I know there are plenty other goodies cooking (I’m looking forward to a stable build with the drag/move feature from 3500) :smiley:

@FredProgGH I’ve actually looked at this before (albeit a slightly more complicated effort) by slaving Reaper to run my backing tracks. The issue is switching songs which means I lose control from within Cantabile (I’d need to have all the songs loaded in Reaper and switch which isn’t so easy as in my set up I control everything from the Master Keyboard I use and once I’m performing never even touch the laptop). The workaround I have… well… works… using a MIDI file in Media Player which contains the tempo and use this as the master. It works fine (atleast it appears to as I can’t see the actual tempo as Cantabile rounds it up) but the audio is in sync to the click from start to finish. This is important for me as I use Kontakt scripts which allow me to use it a bit like ableton or an MPC so sync has to be dead tight (0.1 of a BPM after 1 minute or so and your lagging/pushing). Thanks for the suggestion though - I may look at this again at some point but really like keeping everything in Cantabile!


#5

I was wondering if using a MIDI file would work. Hadn’t considered the song switching issue.

Actually, seems like you could easily spend a couple hours with Ableton or something with good beat detection and stretching and stretch your tracks back to an even tempo. Problem solved! Better to have tracks on an even tempo and easy to import into anything han live forever in a world of tempos like 133.7, right? :smiley:


#6

@FredProgGH That is probably the best solution; cure the cause rather than manage the symptoms. I use Wavelab & Cubase which both have pretty good time-stretching. And will give me the excuse to tidy up some of the eq too! Excellent suggestion - thank you! A world of 133.7 BPM is not a comfortable world at all :smiley:


#7

Starting with build 3576 fractional tempos will be supported.

  • Anywhere you can type a tempo (quick controller, add tempo preset dialog, media file tempo setting), you can now type fractional values
  • Cantabile will display tempos with up to 3 decimal places of precision (overkill, but…)
  • Anywhere where you don’t explicitly type a tempo (eg: sliders, increment/decrement or tap tempo) the tempo will be rounded off to a whole number.
  • Updated QuickController to allow typing commas for locales that use comma for decimal delimiter.
  • Also fixed it so you can’t get a zero tempo in your preset list, like in my screen shot.

#8

This is great @brad. Thanks so much! That will save loading my midi media files just for tempo… Will try this out shortly!


#9

You’ll have to wait till I release the build :slight_smile:


#10

I guess this makes my mechanical metronome obsolete. :grin:


#11

Build 3576 is up now, has this.


#12

Just as good news as the first time… :grin:


#13

Wow, Christmas is really coming early this year! :grinning:


#14

Hello @brad !

Thinking about tempo detection (tap tempo and midi sync features) … does it support fractional values ?

kind regards


#15

Hi Alexander.

Tap tempo doesn’t (it deliberately gets rounded off), midi clock sync should.