Removing double tap on binded midi buttons in Cantabile Solo

Hi All!

Created nine bindings for midi buttons to controller CC 52-60 with controller (no edge buttons), source: main keyboard channel 1.

Unfortunately I have to double tap to resume/suspend.

How do I made it single tap?

It wasnt a double tap before.
Have I changed something in Options?

Hi David,

Resume and Suspend are a toggle type operation. Try switching to “Switch” type of binding instead of No Edge and set to Normal or Inverted depending on your needs.


Thanks, Dave.

It kind of works and doesn’t! :slight_smile:
What I mean is, the buttons are unresponsive at the beginning, it takes two or three presses to activate, then it’s fine. The same with all buttons.
A bit like oiling a gate :slight_smile:

Any idea why that is?

Well it sounds like you should try the “Button” switch setting instead if I understand your description. Try it and see if gives you the behavior you need. It’s the only switch type left!

I tried that, and back to double presses again.

I think Switch is the best option. After a bit of “oiling”!
Maybe it’s the controller keyboard. It’s an M-Audio Oxygen 61.
Any issues with it?
I think it’s a few years old.

Well, you can test the midi input using the midi monitor.

Select the input route in Cantabile for the oxygen keyboard

go to View>MIDI Monitor

Then press the buttons on the oxygen and see what the monitor says you are receiving. It should show the switch behavior type of the actual keyboard switch. This information helps to choose the right binding. If you can post a screenshot of your midi monitor with some switch presses shown in it I could suggest a course of action.

I used the midi monitor and found when I was double pressing, every other press would register on the monitor. Which makes me think, is this a setting on the controller that is doing it?

yes there is a way to set the switches on the oxygen but you need the manual to get the instructs. Sounds like your set to toggle. Set the ones you want to use to momentary type. That’s the most used one. Then find a mating binding type in Cantabile.

Great! Thanks! Will have a look. Thanks for your advice! :slight_smile:

Looking at it again, when I open the song, the buttons activate after 3 presses, then they’re fine.

I think you are right they are initializing with the first clicks and after they are synced they carry on normally. My touch pad app does that too on toggle type buttons.

Hey David,

It looks like the problem is NOT with Cantabile but with your Oxygen keyboard (have you maybe selected a different preset on your Oxygen?

Buttons on the Oxygen controllers can be assigned TWO alternating controller values. These are assigned with “Data 2” and “Data 3” when programming the Oxygen. Then, the button will alternate between these two values. And it seems like (unlike other controllers), these buttons don’t send anything on releasing them.

So what happens seems to be: the first time you press the button, it’ll send the value defined in “Data 3”, next time it will send the value defined in “Data 2” and then “Data 3” again…

What you want to do is to set this beast to send the same value every time, so you need to set Data 2 and Data 3 both to 127. Then, the button should send a CC value of 127 every time you press it → check this with the MIDI monitor.

Next, you need to use a “Controller (No Edge Button)” binding to the plugin you want to resume / suspend, with the value set to “Toggle”. The “no-edge” setting means that this binding will react to every controller value that is not 0, which is what we want here. “Controller (Button)” needs to receive a value < 64 before it will react to another value > 64", so this will not help us here - keep using “no-edge”.

Now, every time you hit a button, your keyboard should send the same value of 127; consequently, your binding should fire every time, toggling the “suspend” status of your plugin. Let me know if this works!

BTW: let me recommend an alternative approach to suspending a plugin: rather than doing that (which may cause some disruption when “waking up” the plugin), you might just enable or disable the route to the plugin (if your machine can handle all plugins being active). To do this, you’ll need to give the route a name so you can select it as a binding target: select the route and go to “Edit->Rename” or hit F2 and give the route a name. Now you should be able to use a binding to enable or disable the route - lots better than brutally freezing a plugin - you can let sounds ring out, and even release notes AFTER disabling the route without any stuck notes!



Many thanks for this info, Torsten!

I downloaded the handbook so trying to introduce your suggestions.
Just wondering if its possible to do a factory reset and it will reset to your suggestions?

My gigs are on thursday to saturday, so I think I might look into your route enabling/disabling after those. Just bought a new computer, so hopefully it can cope with all plugins active.

Thanks again!

Hey David,

TBH, I have no clue what the Oxygen factory presets look like and how they are set up. Behaviors also differ between the different Oxygen versions (not sure which one you have), so I’ll have to refer you to the user manual of your Oxygen controller to set the buttons up the correct way.



Thanks, Torsten. Tried reset but still the same. Will have a look at the manual. It’s the silver 61 key. An old one.