Recording folder not assigned


on my laptop I cannot assign the “Recording Set Defaults” folder path. Whatever I set there, when I stop the recording Cantabile pops up:

“Failed to save recording - Access to the path C:\Users…\Cantabile\Recordings” is denied."

How to fix it? Thank you.

Hi Mistheria,

Permissions under the C:\Users can sometimes be odd. If you create a folder at the top level such as C:\Recordings and point Cantabile there it will probably work fine. Might be easier to manage the recordings there also.


1 Like

Thanks Doug, although the folder is not at that level, it is inside C:\Users…\Documents\Cantabile\Recordings and it must work, it’s simply the Documents folder. It works for Songs, Setlists, etc. Also, it works on my DAW. That’s why I don’t understand why it makes problem now…

In any case, the real issue is that Cantabile does not change the Recording folder path…

One thing you could do running a laptop, if the cd/dvd drive is removable, swap it over for a hard drive caddy and run a second hard drive. Then assign the my documents folder (or which ever directory you have configured for cantabile) to have everything cantabile does, saved to the second drive. This way avoiding any permssions issues accessing C: drive and if the unthinkable happend, where the OS or boot sector/files is/are corrupted, you still have your work on D drive.

If you ever needed the optical drive for anything, then you could use a usb
dvd drive.

HDD Caddy

Thanks @Laura although my Cantabile folder is already on a D:\ drive. The real problem is not the accessibility of the C:\ drive, is that Cantabile does not change the Recording folder path, whatever I type in there. Moreover, this is happening only on one of my computers. On the other computers I can change the recording path on any folder/drive I wish. It is just a strange/random issue that is happening now, never had such issue over years…

Is the file for recordings eg “Default Recording Set.CantabileRecSet”
still in the folder?

an odd one …I’ll throw this out there …
Has it or it’s containing folder been marked read only when viewing its properties? It can happen sometimes, something else may have accessed those directories and changed the properties of files/folders.
If that file is missing it might cause this, I deleted this file once and ran into issues.

1 Like

Where this file should be, in the “Recordings” folder?

Something odd is going on with this particular machine for sure. My suggestion was just for testing but not being able to change the recording path seems to indicate that Cantabile has somehow lost permissions to change files in its user folder.

Sometimes when we get a computer doing something like this we create a second Windows user to test things. Make sure after creating the user to then change its type from “standard” to “administrator”.


It should be in the folder where ever it was setup initially.
click the recordings tab, then click to the little 3 bars under "Monitor)
this should show you where the recordings folder is and this is where
the default recording set file should be

Mine for example is D:\My Documents\Cantabile\Recordings\

Then you can check the properties of the folder and files (if file still there)

1 Like

Thank you. I’ve set the Recording path, it works now, but now a stranger thing happens. Recording starts and stops, it creates the file, I select “Show in Explorer” … the audio file is not there!

Screenshot 2022-06-05 181626

I’ve seen a strange behavior in Windows were you don’t see it when you choose “Show in Explorer” but if you separately go to the folder the file is actually there. In that particular computer there was a problem with a third party file sync app.

Well, as you see in the screenshot, the WAV file is not there…

Have you tried showing hidden files in the windows explorer folder options.

I dont know the way around windows 10 ir 11, my image grab is of win7
I’m sure it’s there somwhere. check the option for “show hidden files and folders” option then click apply and see if anything shows up.

If explorer is set to show icons only try deleting the IconCache.db file as they may be corrupted and not show everything. link below explains this, I found is much different on newer windows.

Failing this I’m not sure what else it might be.

1 Like

Thank you, I’ve checked and scanned full computer and the file is nowhere…

Your path on D:\Documents is what I was suggesting to try earlier in the thread. The sometimes weird behavior in Windows is when things are under the C:\Users…

My suggestions are for troubleshooting the underlying root cause rather than a permanent solution.

BTW, I looked up MEGAsync as its in your pathname. I have moved some of my Cantabile folders to sync also. Temporarily try using a folder that MEGAsync doesn’t touch.

I troubleshoot app issues for a living - when people ask me how I solve thorny issues my response is that I just keeping going at it until something gives :laughing:

1 Like

@dsteinschneider thanks for help debugging. MEGAsync works perfectly and I think that’s not the problem. Everything else is there, the issue is between Windows (10 x64 on this laptop) and Cantabile.

But you don’t know for certain its not the problem. I agree with dsteinschneider since I used to be a software designer and as part of that had to do tons of diagnostic work to debug new systems. Just create a folder in the root (i.e. C: or D:) that MEGAsync doesn’t know about as a temporary diagnostic measure and try it to see what happens. Worst case scenario is you spend maybe 3 minutes time to know for certain whether there is something peculiar to your machine with Cantabile that others are not experiencing.

One other quick and easy thing you could try is running Cantabile with administrator privileges and see if behavior is any different.

1 Like

Thanks everyone for helping out, however Cantabile now correctly saves the WAV files again, in the same D:\Documents\MEGAsync\Cantabile\Recordings where it was supposed to work but it was not yesterday and I cannot help saying why. The only thing changed is that I powered off the laptop yesterday and today it works. Maybe a momentary Windows update or don’t know what…

As for MEGAsync, it’s a good cloud service that keeps all my devices (Studio DAW + 2 laptops for live shows) synced and never created any issues since years. I believe that this temporary issue was not related to it, basically I don’t see it related to Cantabile audio files saving process.

In any case, it works now, thanks again everyone!

Agree on MEGAsync not being the problem - I’ve put it on my list to check out.