RD88 and Cantabile

Hello everyone,

After a near gigging pause of two years (@#&!%) I’ve been reevaluating my setup, I got a second child and had to get rid of my van and my Kronos 88 in flightcase is getting too much to schlep to gigs. It also turns out that the bands that are left either need simple piano/rhodes stuff or are laptop based.

So time to get something smaller and lighter with a good keyboard and an easy laptop workflow; enter the RD88. They marketed it a lot with “easy MainStage integration” and it seems the “DAW Mode” is indeed limited to working with MainStage specifically, although the name implies perhaps more possibilities in the future. In any case, ASIO and midi work fine with Cantabile and though the latency performance isn’t the very best it’s good enough for me. I’m very happy with they way this works, except…

It seems there is no general USB audio volume control. There is a dedicated knob (in combination with shift) but you need to be in DAW mode for it and that doesn’t work with Cantabile (unless some wizard already found a way). Also, it seems the default setting for every scene is “USB AUDIO ON” which is annoying for my purposes. I’ve created a patch where on board sounds are off and only one zone transmits on one channel. I’ve saved this as “USB” and put it in my favorites. I’ve also put all the zones for the main piano patch (one touch piano setting) to “internal” so that they don’t transmit. But every other patch has USB audio on by default and other than dragging my mouse or reassigning all controls there is no direct way to quickly mute USB audio.

I was wondering if there’s is anyone with an RD88 who has experience with this, and how they’ve solved it. Ideally I would end up with a situation where I can use the internal sounds and “turn on” USB sound at will, whether it’s as a layer or by itself.

Hi Sanderxpander,

Have you tried muting the R88 ASIO USB Audio routes from the Cantabile side of the equation. That way you would control the USB Audio muting from Cantabile and not the RD88. It wouldn’t matter that the USB Audio was on by default on the RD88 zones because Cantabile wouldn’t send any audio back to it till you wanted it too. Anyway that’s what it seems like to me.


That would be kind of a workaround, yes. But it means I’d have to physically enable it again when I select my “USB” patch.

On my Kronos, there’s a “global setting” for stuff like this, and then a “bypass global setting” option for each patch. I realize that that is perhaps a niche feature but it is really well thought out.

I’ll experiment some more, maybe it’s possible to mute Cantabile by default but have it respond to a knob I turn when my USB patch is selected.

Actually now that I think of it, best would be to prevent the RD88 from sending midi except on my USB patch, to prevent errant controllers messing up my sounds while I can’t hear. My previous RD170 simply had a “transmit” switch, again niche but super useful. I suppose I could do a similar thing as above but with enabling the midi port, but I’d rather have control from one place (the RD) instead of having to mouse my way through.