Rack States in newer Builds ( Somewhat SOLVED)

As I refrain from updating to newer builds until I have time to test my setup, it took me awhile to install 3209. While everything seemed to be running smoothly, I started having trouble with S-Gear. I created an S-Gear rack before updating, and had no problem. Since updating, I started getting error boxes stating that the presets could not be found. Understand that S-Gear has 100 presets, which means I had to close out 100 error boxes to get back to a normal window. After I closed all the boxes, the presets were there and usable. I checked my rack and noticed that there were bindings automatically set up. One was a binding linking Main Keyboard to a midi in to S-gear. I deleted it. The 2nd binding was a load rack states, which loaded every preset as a state. I disabled that binding. I did not not set those bindings up, and really wasn’t expecting 100 error boxes popping up during my most recent gig. It seems to happen only occasionally, and I had no problem until the gig ( go figure ). I am still testing and hoping that disabling the rack states load will cure the problem. If anyone else is experiencing this, would love to hear from you.


Hi @Corky,

Sorry you’re having these problems. I’m a little stumped at how bindings could be automatically created - that seems very odd and can’t think of any rational explanation. Similarly for the S-Gear problems I can’t think of anything I might have changed to affect this.

What build were you running previously - I’ll do a quick audit of changes to see if anything stands out.

In the meantime, if this happens again could I get you do:

  1. Do whatever you need to do get everything loaded but don’t save or close yet.
  2. Grab a copy of you settings files (Tools -> Open Settings Folder) settings.json, log.txt and log-previuos.txt
  3. Also grab a copy of any song and rack files you have loaded.
  4. Zip them all up into “before.zip”
  5. Once you’ve got it working again, save everything, close Cantabile and grab another copy of the same files as “after.zip”

Send me the files and I’ll see if the difference between them provides any clues.



Hi Brad. I worked on this for awhile today, so, unfortunately I have already saved my progress before I received your message. I reverted back to 3179 several weeks ago because I was getting slow load times, sometimes crashing. 3179 was stable for me and I had some gigs, so I was good until I had a few days to work with a newer version. I loaded 3209, had a few invalid bindings which I fixed, but when I would load S-Gear rack, occasionally I would get the pop-up error boxes stating the presets could not be found. I would have to click ok on every pop-up ( 100 of them ) to get back to normal view. After that, the presets were there and working. I finally discovered 2 bindings on the S-Gear Rack. I never had bindings on this rack. One was Main Keyboard with a midi in to S-Gear. I do not have a “Main Keyboard” setup as I changed it to “Key 1” when I first started using C3. I deleted that binding. The second binding was set to load rack states on rack load. I disabled this binding, saved the rack, and, after several tests, can say I am problem free at this time. Since I have gigs starting tomorrow, I am going to stay where I am at. I am going to recreate this problem next week so I can understand why the presets would do that, but I don’t understand where the bindings came from as I never created them. I will send the information you requested if I am able to recreate this. Thanks for the reply, and, as always, thanks for everthing you do.



Ah, 3179 was before the new binding mechanism. I’m guessing you had some triggers configured on those racks. From 3182 triggers no longer exist and are automatically converted to bindings - could that be where they’re coming from?

As for S-Gear - I don’t know what might have happened there.


Ok, so after gigging this weekend, I had a long session with C3. I only used S-Gear on about 6 songs, Amplitude on 3 songs. Amplitube worked perfectly as always. I had problems with S-Gear on 3 of the songs, showing the 100 error boxes again. I found that if I had S-Gear in a Rack, it would automatically load all the presets as states. They were all playable, and why they would show up in error boxes as not found still mystifies me. The 3 songs that S-Gear was not in a rack loaded perfectly and presets set into the song were saved. The S-Gear rack did not save the presets unless I loaded them from the preset states. Also, as I mentioned before, I had no bindings set for S-Gear, but due to the version change, and making an S-Gear rack, a binding was magically created to setup a preset state on load. Amplitube is not in a rack.

This is the states view on the S-Gear Rack

Here is the magical binding that was created.

I tried disabling the binding, but I couldn’t save my my preset for the particular song. So…I gave in, kept the binding and use S-Gear as a rack only. As long as I select a preset from states, it works fine. No more error boxes. Thank goodness my keyboards haven’t had this happen. Thanx for the help Brad.

P.S. I just noticed the binding sets up as “MIDI in” on channel 1 as a Program Change with a value of 9. Apparently not causing a problem. Have no idea where that came from as I am using a mic input.

Hi @Corky

Almost certainly that binding came from a trigger in the older version rack file. Have you still got the previous version of the rack? If you check the triggers tab I’ll bet there’s something there.

As for the problem with S-Gear I have no idea but I’ll ping the developer and see what I can find out.


@brad I do have some backup versions. I will certainly see what I can find. Thank you again for your help.


Hi @Corky,

Got a reply from Michael at Scuffham:

I’ve come across this problem on a few occasions and the issue has been due to file/folder ownership or permissions. If S-GEAR has created presets under the admin account then the plug-in is loaded and run under a user account, it may be that the plug-in is unable to load preset files.

I had one other customer who experienced this issue, with Windows 7 and PT10.

The customer solved the problem with an unusual solution, but it might be worth trying in this case too. In this case the problem was solved by:

  1.   Uninstalling S-GEAR
  1.   Reinstalling WITHOUT the 32bit plug-in option
  1.   Uninstall again
  1.   Reinstall WITH the 32bit plug-in option checked

It seems that by allowing the installer to run first with the 32bit flag unchecked, then again with the flag checked, somehow refreshed the 32bit installation. It could be that the 32bit registry entries were updated correctly during this process.

Another possibility is to check folder permissions on the C:\ProgramData\Scuffham Amps folder where preset data is stored. Make sure that everyone has full permissions.

You can refer the customer to contact@scuffhamamps.com and I will try to help.

@brad Thank you Brad, I will try that.

1 Like


I changed permissions as suggested. Everyone now has full control. This seems to have worked as I have had no problems yet after multiple runs. If I do have further problems, I will try the uninstall/install suggested. Thanks so much for the help and my regards to Michael at Scuffham.


1 Like

I have solved part of this problem, but have discovered a few things in the process. I know there are several of you in the community using amp sims, in particular S-Gear, and was hoping I could get some feedback on it’s use. I use several different sims for different things, but I find S-gear does a great job for the clean sounds.

I can load a rack, or an individual plug of S-Gear, within a song, no problem. If I make a set list with more than 1 instance of S-Gear, and pre-load that set list, all but the 1st S-Gear plugs will produce a file error box concerning presets. I have to manually close the 99 error boxes (for every preset) every time to continue the pre-load. After many hours of testing, I know the following:

  1. The 1st SG plugin in the set list will load properly; it doesn’t matter whether in rack or not, or the preset selected.
  2. All following SG plugs after the 1st will not load without error boxes.
  3. If I have 2 songs in a set list, both with SG plugs, and DO NOT pre-load the set list, I can load and use the first song. But IF I unload the 1st song plug before selecting the 2nd song, the 2nd song will load properly.

Both @brad and I have contacted the developer, and though they are very co-operative, they know there are a few problems with preset files for some people. I have tried everything they suggested without solution. I was wondering if any S-Gear user may be having a similar problem in Cantabile 3, or other hosts. I would love to hear any comments or possibile solutions from the great minds in this community.

Many Thanks


This sounds like an issue with the plugin when running multiple instances. I’ll ping the developer and see if that rings a bell.