Question about first column in main view


#1

I don’t know if this is “by design” or a bug, but is there a reason that the first column in the main view (usually “State”) is not resizeable from within the UI? Occasionally (very rarely, actually) this column has somehow changed size, taking up half of the screen – not intentionally on my part. When this happens, the only way I could find to resize it back to my desired width is to edit the settings.json file in a text editor. This is the only column that I cannot resize by dragging the column header border. A minor annoyance since it has only happened a few times, but still an annoyance.


#2

It’s fixed width because there should ever be the need to resize it. I’m not sure why it would get resized to the wrong size. If that happens again can you send me a copy of your settings.json and I’ll see if I can figure it out.


#3

Thanks Brad. That’s what I suspected. I have no idea why it would have resized. If it ever happens, I will try to remember to capture the settings file. But it has only happened twice in all the time I have used C3.


#4

By accident, I managed to replicate this issue. I had a VST plugin window and was trying to drag it to the edge of the screen so I could see the Cantabile window without closing the plugin window. Instead, I accidentally clicked and dragged onto something in the Cantabile window and dragged (while the plugin was still in the foreground). Here is a screenshot after that happened, along with the settings and log files after I closed Cantabile.

CantabileFirstColumn.zip (25.9 KB)


#5

Hi Roland

I did the same thing last week. I was in a hurry and shut Cantabile down, and restarted it. I meant to go back later to see what I did, but didn’t remember this until now. I am using 3553. Will let you know if I figure it out.

Corky


#6

Hi @Roland_Robertson

Thanks for the info.

  1. Can you reproduce this?
  2. After you restarted Cantabile, did it go back to the normal width?

Brad


#7

FWIW, this has happened to me on multiple past builds while editing (not at a gig!) and a restart was the only fix I found. It was so rare that I just carried on. Its only been the first column on both bindings and route page after it happens. The observation that it happened on a swipe has got me trying to recall if that was the case for me. I will keep a better eye!

Dave


#8

I cannot usually replicate this on-demand, although I might be able to now that I have noticed when it was happening (while editing, as @dave_dore noted) and because of an attempted click and drag with another window open. I will not be near my music computer for 10-12 hours, but I will try at some point. (Full-time job taking me away from more enjoyable pursuits!)

I noticed that when I closed Cantabile the settings.json file was updated to have the larger width. Rather than restart Cantabile to see what would happen, I just edited the settings.json file to have the same value for that width as is in the “last good” settings file. So, I’m not sure if restarting Cantabile would have fixed things. I don’t think it did when I had the problem months ago.

Sorry I can’t be of more help…


#9

I spent 45 minutes trying to recreate it last night to no avail.

I also encountered something new at a gig last Friday. During one song, I switched to 2nd song state, and within seconds, it switched back to 1st state. Tried it several times, but it consistently kept going back. I’ve also been trying to recreate it, but nothing.


#10

Yeah it’s elusive but definitely happens at random times that I can’t figure out.

Not had any other reports of anything like this. There’s nothing I can think of in Cantabile that would cause this - state changes are always driven by external events. Any chance you had stuck button on a controller or something?

Brad


#11

@brad

That is what I supposed, but I have a floor switch and lower keys for switching. Tried using both, they would change state, and it would return to 1st state. Will test them out again. Could be floor switch. Thanks Brad.


#12

Didn’t get a real chance to try anything in the past 24 hours, but thought I’d mention that I was not connected to any controllers this time. I was sitting in a recliner with just my laptop and integrated touchpad.


#13

I had this very thing happen to me when I had a song loaded and then I went into Cantabile’s software options and made a change to the audio engine buffer size. When I clicked ‘OK’ to save and exit the options window I noticed the first column in the main view was super large and I couldn’t resize it. After closing Cantabile and then reopening it everything was fine and I never saw it act up again since.

Matt


#14

The suggestion about the controllers was in relation to Corky’s other issue with state switching - nothing to do with the column width discussion.


#15

Quick update: I have been unable to reproduce the problem (as I thought). It happened by accident and is only the 2nd or 3rd time that I have seen it despite using Cantabile 3 since it was released.


#16

I wasn’t trying but just had this happen. I added a few routes in a rack testing some new gear. I moved the trackpad mouse to the top of the page and this.

@brad


#17

Ugh!

There must be some magic pixel somewhere that if you click it during the correct phase of the moon while the window is a particular size and while pulling the appropriate facial expression weird stuff happens.

I’ll take another look at this today.

@RackedBrain - do you know if you clicked in the header area near the resize columns dividers at all when this happened?

Brad


#18

LOL! You need to compile all of the reported incidents, check the date/times, take into account the various time zones and current weather conditions. You might find a correlation!


#19

@brad I could easily be convinced it had something to do with the hated trackpad. I have it set on the least sensitive setting. Yet, occasionally when I try to scroll across the screen, it will try to select everything and things will drag around. I suspect I’m dragging my knuckle on the track pad and it see it as a double click or a two-finger drag. I wonder who else with this problem was using a trackpad?


#20

2 incidents doesn’t exactly make for conclusive evidence, but I was using my laptop’s touchpad when this happened to me. For what it’s worth…