Q re changing Audio and MIDI devices

Thanks, but so far that is not the case…each song I open declares that the devices are missing - I then need to manually edit the input devices to reflect the change - the output audio is fine as C3 seems to just apply that as a global setting anyway.

I must have misunderstood what you were describing. What I am describing is done in the Tools/Options/Audio Devices and Midi Devices regions. I wonder if you need to re-start Cantabile for it to “take”?

Terry

Nah, I don’t think that does it. TBH I think it is probs asking too much for C3 to do this. I just needed to clarify it so I cna get cracking on creating all my stuff on C3 - I have just converted all 150 setups from C2, and THEN had to re-assign the missing Audio/Midi devices to the new ones in the rack itself. I think I will have to stick with this hardware arrangement now - I would hate to have to do for 500+ racks :open_mouth:

PS: To clarify, the new audio and midi hardware devices are available as soon as you change them in prefs - C3 just does not reflect the change in a song rack itself.The song rack still has the old hardware listed, but says it’s missing.

Oh, I see now. I don’t suppose even having the same exact name would work then, as it is likely looking for some registry entry. Brad may chime in shortly on this! @brad!!! :wink:

Yeah I think you are correct Terry. I only changed as the audio device was generating too much noise through the P.A. whihc was not apparent in the cans. So I think I’ll be sticking with the new setup.

Be nice for some way of asking C3 to auto change the devices if asked by the user…in case of hardware changes in the future, but as I wrote earlier, I think it may be too arcane to get it to work smoothly - I have NO idea of how one would implement this hahaha!

Dennis

1 Like

Hi Guys,

Have you looked at the aliases on on audio and midi ports.

eg: suppose you have a pretty standard setup like this with Main Microphone and Main Keyboard:

Now you won some cash and bought a “Gold Microphone” and a “Gold Keyboard”, you can edit the port names and put the old name in the aliases field:

Do the same on the MIDI port, close options and Cantabile automatically renames the routes:

Also, it’s not obvious from the above but you can put multiple aliases in by separating with a semicolon ie: ; comma ie: ,

See this: https://www.cantabilesoftware.com/guides/multiConfig

As for backup/restore what you want is the settings.json file in the folder that can be located using Tools -> Open Settings Folder.

Brad

1 Like

Well, technically speaking, I have LOOKED at them, but I didn’t know what to DO with them until now! :wink:

This is fantastic! My Gold Microphone is due here any day now!!!

Terry

1 Like

Does this work OK even with importing setups from V2, which was the original trouble spot Dennis ran into?

Terry

Yep, this is done at the time the routes are bound to the environment - much later than session upgrade.

And can you confirm Brad that it not only swaps the names but also “sees” them as viable and active hardware ports?

It’ll see them as as active and as viable as they are configuring in options. ie: yes, it should.

cool, thanks Brad…

Okay, finally got around to trying this as the new controller just arrived (replacing the A-70 with a Numa Nano).,

I must be doing something wrong as C3 does not seem to transfer from the old input (UM-1) to the new (Numa Nano).

In the alias box I put the Numa Nano in the top field and UM-1 in the bottom field, then press okay. However when I laod a song, the UM-1 still appears in the route and no midi activity is seen. What am I missing here?

Thanks

Hi Dennis,

What is the order of your connection?
nano midi out >um1 midi in >um1 usb >pc or mac ?
If I understand correctly you shouldn’t need to add numa nano as alias at all. just plug to um1 and use the same old config or add the numa nano in the alias field and leave um1 in the top field.

regards

Dennis,

As I understand this, you need to add a new device, not change the settings in those windows for the existing one. So, hit add, and then put in the name of your device and select it from the drop-down menu. After that is done, in the alias field you put in the UM-1 as the alias (spelled the same as it is for its own setup, of course).

As an aside: I’m still running one machine on an old UM-1 myself - Roland no longer supports it with new drivers for Windows 10, I understand, so I use it on a Windows 8.1 computer as an idea machine.

Terry

BTW - I could indeed have it backwards! So take anything from me with a grain of salt.

Terry

Dave, I am ditching the UM-1…no need to have two midi interfaces connected :smile: however looking at your post I think I may have them in reverse order, so I’ll try that.

Dennis

Terry, the 8.1 driver works quite nicely on W10

Dennis

1 Like

Hey Dennis,

If your not using the um1 then check out what Terry said and add the new device (Nano) using Add. Cool about your new board let us know how it goes. :grinning:

Thanks Dave - yeah I had already added the Nano - but as I wrote above I think I may have reversed the order in the alias box - trying it now :smile: