Problem with Voicemeeter and audio interface

Tags: #<Tag:0x00007f9786ee83b8> #<Tag:0x00007f9786ee8278>

Hi guys,

This is my issue. I give and record online piano video lessons. For recording I’m using OBS studio on a Windows 10 PC with i7 9700, 16GB ram.

I was able to add my keyboard as midi input and apply a piano VST sound.

As audio device I used Voicemeeter Input, so that I could send the output to OBS studio.

This worked perfectly, a part from many glitches that I still need to take care of. But the problem came with my microphone.

I have a Rode smartlav+ linked to my audio interface, an M-Audio M2x2 (see image attached). And here comes the problem.

Since the audio device selected is Voicemeeter, as audio input I’ve been provided VM-VAIO 1 VM-VAIO 2 etc… So it seems impossible to me to add my M-Audio interface to get the mic signal.

If I use my audio interface as the audio device in Cantabile, well, I fix everything up, but I find no ways to send the signal to Voicemeeter and eventually to OBS.

Is there anything I can do here? Do you guys have any idea on how I can use the mic in my audio interface and Voicemeeter altogether?

Thank you so much.

Paolo

Hi Paolo,
welcome to forum. Here we have a true Voicemeeter and OBS guru, @terrybritton. He’ll read your post and help you.

Paolo

Hi Paola,

I take piano lesson online and also Facebook livestream piano performances. I see your dilemma about how to incorporate a microphone attached to sound card into the Voicemeeter setup. I think there is a way to do this, which Terry Britton may be able to help with. I eventually went a different route, using my DAW, OBS, Scarlett 2i2 and my MXL Mics 770 microphone. Also a free Reaper plugin called Reastream. A rather convoluted process but in the end it works fine. If you want to go that route, check out this video

I am also setting up lessons on Zoom, and am following @terrybritton advice. He has several instructional videos on his YouTube channel. Here is one of them:

There are other Webinars he did on the subject…just take your pick. I am running Cantabile (as a DAW) into Voicemeeter, into OBS, into Zoom. I am also using a Focusrite interface. Terry’s video says so much more than I can explain in a thousand typed words here. Basically, you will need to select your M-Audio ASIO driver in the VoiceMeeter input. That will link your hardware to VM, which will run your audio.

Regards

Corky

Corky is entirely correct - the whole secret is to select as the A1 output device the ASIO version of the M-audio interface. It will appear at the bottom of the list. Then, Voicemeeter and the M-Audio interface will be linked to the buffer settings of the M-audio.

What I do is go into the Voicemeeter settings then into where it says, “Patch ASIO Inputs to Strips” and I assignn the channel I use for the microphone to the first strip, in my case as 1 and 1 to make the mono input into stereo (appearing in the center channel). The still from the video above actually shows this setting. Don’t use the strips own drop-down selector above the strip - use this avenue and everything will stay in the ASIO realm.

Terry

1 Like