Priming a portamento


I need to silently ‘prime’ a portamento for the first note in a synth solo. I want to first note to have a downward zap to give it that bit extra.
The new bindings features make this very possible but I was wondering if anyone has tackled this before and what solutions they have found.
I feel some sort of way of sequencing bindings with delays would help.
The way I do it now:
A momentary button to send MIDI volume to 0 when pressed and then 127 when released.
Another button to play the high note that primes the portamento.
I press and hold the first button and then press and release the 2nd and then release the first.


That’s always been my approach. You could, of course, use that beautiful old stalwart, the midi file! That gets all the data out with one button push.

1 Like

I like it, nice idea.

1 Like

VERY nice idea!

(Confession - I once wrote on a shopping list, “Green Olives with Portamentos”. That was back in the Seventies, so I cannot even blame old age for that one.)

1 Like

I couldn’t resist checking it out.
Of course, the major thing to watch out for is that the note on event is far away enough from CC127 that you don’t hear it! It’s obviously not the kind of string that you can program to be lightning fast.
Of course

you could always issue the CC7@0, then the note, then a bypass to flush tail, and then the CC7@xx. That’s if you need it really fast and want to amuse yourself… which I do! ha ha!
Checking it out…

I’ve used Ade’s approach in the past, using a MIDI sequence in a media player, triggered off a song-state change binding (usually one or two song states before I need it). In my case, it was for CS80v in polyphonic glissando mode, where I needed to make sure all 8 notes of polyphony had been reset to a single note. It worked great, although it’s slightly unnerving to know that when you go to a certain song state some notes are going to be played automatically on your behalf, and you just have to hope the muting works :slight_smile:

1 Like

Well, the resume/suspend trick does work.
Even if the sound has a huge long release, as soon as the midi file is run, the volume sets to off, its ‘start glide from here’ note is set, the plugin toggles its resume/suspend which flushes out any tails, and the volume is brought back to the desired level.

In addition, you can use the same midi file and have the midi route settings transpose the start note wherever you like, for up or down glisses.

This experiment has actually revealed a couple of anomalies that could be in my programming - but could also be related to a Cantabile issue:

The timing is crucial, if the suspend/enable are not separated by a reasonable distance, Cantabile does not respond well. I’m at 1/16th note @ 120 BPM.
Also, the resume/suspend status light does not flash if the events are too close, even though it’s patently doing something.

Perhaps the thresholds for these controls have not been set to anticipate rapid fire automation? Even as I type that it looks like BS :slight_smile:

Either that or I have done something bad in the midi file. I have CC3 issuing a 0 and 127 in order to toggle the Res/Sus. Then we’re into which binding is the most appropriate. What I really want is an absolute which only sees 0 as Suspend and 127 as resume.
I’m a bit knackered at the moment and I’ve lost the plot. It’s working, but I’m sure I there’s something not quite right.

Disclaimer: Those synths that we’ve already identified as not allowing flush, such as Synth1, can’t use this method safely.

That’s entirely possible - Cantabile will update the screen as part of the regular Windows screen repaint mechanism. If events are too close together they can easily be coalesced into one repaint cycle and not seen on screen.

Latest experimental build includes some fixes for flush tail sounds - I’m interested to hear if anyone is still having problems with this.

That’s another neat trick.

Hi @brad
3225 is not flushing Synth1 tails, whether they are long release times or DSP fx.

yup, bindings with delay can help you here!

first binding sends a volume=0, next two send note-on, note-off, last brings volume back up.

I’m actually using this to AVOID a portamento on the first note, since Hive always starts the first portamento from middle C. So I init it with this note to make sure I don’t have this awful howl on my first note…




Hi Ade,

Just tried it here seems to work fine. Are you sure you’ve turned in on?


Hey @brad,
Definitely not working on my system. Release tails head off into the distance, repeat echoes continue to bounce and the ‘flush tail’ command is on.
I’m running 3225, which is the latest experimental build at the time of writing.

Hey @Ade,

OK, I’ll need to check it out. Can you send me a song with the plugin configured as you’re seeing the problem. Also what version number of Synth1 and which platform Cantabile and Synth1 (x86, x64, bridged, non-bridged etc…)