Prevent screen saver option not working?

This is certainly a minor quibble, and there are workarounds for this, but this is a feature that I liked in v2, and was happy to see the option in v3. But it is not preventing the screen saver for me. Unfortunately, disabling the screen saver is not an option for me with my primary laptop. (The feature in v2 DOES work on the same laptop.)

Thanks Roland. I’ve fixed it, will be in the next build.