Potential fix for Roland Zenology


#1

Hey All,

I’ve had a number of users report issues with Roland’s Zenology plugin - essentially where the UI becomes unresponsive in hi-dpi modes after certain actions (not sure what).

Basically I think it comes down to the plugin committing in the same sins as Roland’s VST 2 plugins (don’t get me started) so I’ve put in the same workarounds for Roland VST 3 plugins. Certainly it fixes some other issues with it’s menus and some other display issues.

The fix is available now in experimental build 3655 so interested to hear if this fixes the hang issue (as I couldn’t reproduce it myself).

Brad


#2

Hi!

Seems that fix doesn’t work unfortunately.
Just changed some presets then chose one and GUI stopped responding
(VST3 version, non HiDPI mode)

kind regards


#3

Hi @Alexander

Thanks for the update. I’m getting mixed messages about this - some reporting it’s fixed, others not. I’m still looking into it and will post back when I know more.

Brad


#4

Quick update - I’m still looking into this, but haven’t been able to reproduce any issues here with the latest builds of Zenology and Cantabile.

If anyone is encountering issues with Zenology can you please let me know:

  1. What version of Cantabile and Zenology you’re running
  2. What actions lead to the issue (reported issue is GUI locks up/stops responding but audio processing still works).
  3. What version of Windows you’re unning.

Brad


#5

Hi!
For the record
Latest version of Zenology
Windows 7x64
Cantabile build 3655

Playing external keyboard while changing presets via preset browser leads to an issue

Kind regards


#6

I’m getting crashes with Cubase too, FWIW…

P


#7

Just updated to Zenology pro and have the GUI lockup issue.
Windows 10 64bit
Cantabile 3655 64 bit
Zenology pro latest version
Switching presets causes lock up. Sometimes right away other times after a few minutes of playing around.


#8

I should add that although I had Zenology installed prior to the pro update, I did not spend any time with it so am unsure if the issue existed prior to the update.


#9

Hey guys,

This is my top priority to investigate when I return to Cantabile development next week.

I’ve been collecting information about this over the last couple of weeks and while I haven’t yet been able to reproduce the issue myself, I’ve had a number of hints that this might be related to running multiple instances of the plugin.

  • Has anyone had issues with this when only ever having loaded a single instance of the plugin?
  • It would be interesting to disable Cantabile’s multi-core support and see if this problem still persists (Options -> Audio Engine -> Number of Audio Threads -> 1 - Disable)

Brad


#10

Hi Brad, I see this with a single instance.
John


#11

Same here


#12

Yeah, I get the issue with just a single instance. I’ll have a go with the multi core thing and get back…

P


#13

I have using Zenology (and Zenology Pro) consistently since it first came out, and the only issue I ever had was during the first few days, where I experimented with different Cantabile settings. I have not seen any issues since, using a single instance or multiple instances of Zenology.

The one thing I will note is that I always have the Hi-DPI User Interface setting Disabled, because I have seen issues with various plugins - including those first few days of Zenology - if I have it enabled.

Other settings of note:
Main Window Scaling: 120%
Other Window Scaling: 120%
OpenGL: enabled
Number of Audio Threads: Automatic (4)
MultiProcessor Mode: Agressive
Thread Affinity: Disabled (System Controlled)
Double-precision audio: disabled

Hope this helps!


#14

I’ve now spent two days on this and as usual with Roland plugins, this is almost certainly a problem with Zenology.

What I know so far is that this is related to the Zenology’s preset selector window. When it’s displayed it disables all the other Cantabile windows - including the zenology plugin editor, Cantabile’s main window, internal windows used by Cantabile for comms, windows created by other plugins, the console logger window and more.

It really has no business doing this.

Worse (and this is the real problem): when that preset selector window is closed it occassionally doesn’t re-enable the same windows that it previously disabled leaving Cantabile’s main window and the zenology plugin gui window are left disabled and all future interaction with Cantabile is out of the question.

It’s not related to threading modes, multiple instances, hidpi modes or anything else - it’s strictly a badly behaving plugin issue.

Not sure what I can do about this except explain it to Roland and hope they’re interested in fixing it.


#15

Maybe I haven’t noticed problems because I never keep the editor windows open when playing sounds (and certainly during a gig). But this is good information to know. It’s a shame because I do like the plugin.

Something I would be curious about (not that it’s Brad’s responsibility to determine this): do other Hosts and DAWs have similar problems with Zenology? If not, do they treat the VST windows differently?


#16

As much as I loved the sound of the Roland cloud synths they were in general very badly behaved, including not liking being moved to an install location of my choice, despite the installers allowing you to do that, and when they got updated you ended up with an inconsistent state as they updates went to the default location. Trying to uninstall them left a hell of a mess in AppData and registry, so I gave up on them.

From what Brad is saying, it sounds like Roland have still not learnt to play nicely…


#17

I think I may have found a workaround for this… still testing but looks good so far.


#18

Experimental build 3656 should fix this. Please let me know if problem persists.


#19

Hi Brad, Just installed build 3656 and played around with Zenology for about 20 minutes and have not experienced the problem yet!
Thanks or all your efforts! This is great support.

PAul


#20

Same here, can’t get it to go wrong.
John