Possible bug in Background Rack w/ MIDI Filters?

With my current setup in a live show, I use Program Change buttons on one my keyboards to trigger the next song or song part, by using Bindings in the Background Rack. I also added a MIDI Filter to specifically suppress Program Change event.

But I still see the Program Change events get passed to some of my Plugins (which are all in Racks), unless I add a MIDI Filter at the Plugin level within each Rack. Should the MIDI Filter in the Background Rack be keeping this from happening, or am I doing something wrong. (Note that I have not tried to see if this bug – if it is in fact a bug – applies to more than just Program Change events.)

Hi Roland,

A filter in the background rack won’t cut it. The event is already broadcast one level higher than each of the racks - so you’ll be filtering in the background rack but not anywhere else. The background rack runs in parallel to the song and other referenced racks - not in series/before it.

There are two ways you can solve this:

  1. Set the routing mode of the binding to suppress. Right click on the binding and check the routing mode. See this blog post for more. Since bindings hook in fairly early to the midi chain they have the power to suppress the event before it’s broadcast to the racks.

  2. Set the suppressing MIDI filter on the MIDI port itself - Options -> MIDI Ports -> double click the port -> MIDI filters.

Let me know if that helps.


Thanks Brad. It makes sense when you explain it. I just didn’t think it through enough.