Plugin UI visibility on load

What’s the logic that defines whether plugin UI should appear at Cantabile (or song) startup?

I’ve noticed in my current setlist, if I save all and close Cantabile, with no plugin user interfaces present, when I come to start Cantabile again, the UI of two plugins invariably (possibly always, not sure) are visible, when I wouldn’t expect them to be.

The only thing that differentiates those plugins from others (that don’t behave like this) is that I have bindings set up to show/hide these plugins, on receipt of certain MIDI control change messages from my controller keyboard. But when starting Cantabile, these control messages are not being sent. So it’s as if the bindings that show these plugin UIs are being triggered on launch. Very peculiar. Slightly irritating, but not a big deal. Is this a bug or a feature?


The visibility of the plugin UI is saved when the song/state is saved. It’d be good to know if this is save/load problem or a binding/trigger problem. Can you disable the bindings and see if the problem still happens?

Yes, if I disable the bindings, the problem disappears. Here’s what the bindings look like:


Actually, my screenshot above also illustrates something else I was wondering. Why is the “Play” triangle on some bindings disabled, when they’re working like triggers?


Hi Neil,

Could I get you to double check this. I thought I reproduced this, but it was because the song was saved with the plugin editor visible. Because closing the plugin editor doesn’t mark the song modified it’s easy to think you’ve saved one way when you haven’t.

Try this: open your song, re-enable the bindings, close the editor, save, close and reopen and see if the editor popups again.

Because bug. Will fix.


Yes, it does…


Hrm… OK weird. I’ll try again to reproduce it.

Quick question: are your bindings in a rack or in the top level song?

Logged here for tracking.

Aha, I’ve found the cause…as usual, user error!!! The plugin in question was living in the background rack, and I guess must have been open the last time I saved that. I just forced a resave of the background rack with the plugin UI closed, and the problem has gone.

Apologies for your time spent investigating this! Anyway, mystery solved :relaxed:


No problem, glad it’s solved!