Plugin loading performance and Omnisphere/Keyscape sounds not loading up unless in Pre-Load mode


#1

Gang,

So I was hinting on the TRITON VST thread that I encountered some issues.
For the context, I’m still transitioning from VIP as my host, taking advantage of the 1 month trial. I’m on a fast SSD laptop with 16GB of RAM.

So I compare songs loading in Cantabile vs in VIP. I saved the same Triton patch as a bare song in Cantabile (with just routing from the main keyboard) and in a simple patch in VIP.
Loading the song in Cantabile takes 3s~4s
Loading the patch in VIP is < 1s
This is the default piano sound of the TRITON which is a 16MB sample. So obviously, it’s more about the plugin itself than the sample payload.

If I take a very simple sample based patch in Omnisphere, again, it takes <1s to load in VIP and 3~4s in Cantabile.

Things get really messy if I take a heavy Keyscape sound such as the LA Custom C7 or the Wurlitzer 200A, it takes 2~3s to load in preview mode in VIP.
With Cantabile, most of the times, it never comes up… I have to double click on the plugin, which loads its GUI, and there, select again the sound (double click the already highlighted patch). Then it finally enters preview mode instantly.
I have tried changing the preset mode for Omnisphere but I had the same results.
I have not the issue with other Omnisphere libraries. Only Keyscape.

Now the better part: if I activate “Pre-Load” mode for the set list, everything loads fine in Cantabile! And of course, song switching is instant after that.

So Keyscape is not really usable for me with Cantabile unless I’m in Pre-Load mode.
What am I doing wrong here?


#2

Hi Le Heros,

The only explanation I can offer is that Cantabile loads the VSTi and the start up samples in Ram on a “preload” for your sounds in Keyscape and then disk streams what ever else it needs. Without set list preload Cantabile must reload the VSTi and samples with each song change, which accounts for the time it takes in your observations. It’s the nature of the set list preload to allow the VSTi to be resident in memory. Using Linked Racks to hold your VSTi’s also helps fast loading because the rack can be loaded in memory and serve multiple songs in the set list.

Dave


#3

Hi @dave_dore

The idea of having a linked rack for a beautiful piano sound that is always available is very nice.
Alas, I have tried Omnisphere/Keyscape inside a linked rack but I still have the issue: the sound won’t load up when I select the song, unless in Pre-Load mode.


#4

More news on the issue:
It seems that the first time I load a song with an Omnisphere/Keyscape sound, it works. But not after that.

Example:
I have a Test set list (not in Pre-Load mode) with 3 songs: Test 1, Test 2, Test 3 and Test 4
Test 1 is a simple Triton plugin
Test 2 is Omnisphere with a simple patch (not Keyscape)
Test 3 is Omnisphere with a Keyscape patch
Test 4 is Omnisphere with a Keyscape patch

When I start Cantabile with the Test Set List, having Test 1 by default, Test 1 loads correctly.
Moving to Test 2 => OK
Moving to Test 3 => OK
Moving to Test 4 => KO (no sound, I have to enter Omnisphere’s GUI and double click on the patch to force loading)
Moving to Test 3 again => KO (same procedure)
Moving to Test 4 again => KO (same procedure)
Moving to Test 1 => OK
Moving to Test 2 => OK

Now if restart Cantabile with the Test Set List, having Test 1 by default, Test 1 loads correctly.
Moving to Test 2 => OK
Moving to Test 4 => OK
Moving to Test 3 => KO
Moving to Test 4 => KO

Again, no problem at all if the Set List is in Pre-Load mode.

@brad just in case this helps: I can see in Windows Task Manager that when a song is KO, it does not take the usual amount of memory it should take (the Keyscape sounds being several hundreds of MB, it’s easy to spot when they are really loaded)


#5

I cannot judge what the issue is with this, but just to state that I run Omnisphere and Keyscape since more than 1.5 years in Cantabile without any issues. I am also gigging with it. As a matter of fact, I stopped using VIP for songs - it crashed all the time and zero user support - and use Cantabile. Not looking back, I use VIP only as a search engine to find patches within my VSTs
I use larger Keyscape patches as well. no issues. With 16Gb RAM I am fine until now. Using linked racks for sure. I have dedicated linked racks for Omnisphere and Keyscape seperately.

Ad


#6

I’ve had similar issues with Keyscape - immense load/unload times and actually C3 crashes from time to time - Keyscape keeps a ridiculous amount of file handles open. See here: https://community.cantabilesoftware.com/t/ridiculous-number-of-file-handles-in-keyscape/4701

I ended up thinning the sounds (in the mix you don’t hear the difference) and I preload everything. Given that I’m pretty happy with Keyscape now.


#7

I definitely would like to ditch VIP now (although I don’t have any crash at all, it is quite fast for me and it loads Keyscape perfecty)… sorry I’m still using it for comparison all the time as I still gig with it.

Knowing that you can use Keyscape without issue in Cantabile gives me hope.


#8

Oh thank you for pointing me to this.


#9

Something I should have said before indeed: I’m definitely using Thinning in Keyscape (+Sustain realism off on the C7) in live situation.
It does not seem to have an impact on my issue: I have tried with or without thinning and it’s the same: only loading the first time.


#10

@Toto, I hope Brad can help you. Sounds to me there is another issue. I do not even use thinning in Keyscape and Cantabile songs go ok, also with the larger patches. I use in the gig several Rhodes, Wurlitzers and the Yamaha C7 patch for some songs, and have no issues at all. Unthinned, with 16Gb RAM, all STEAM files on my C-SSD drive, and with an not even that fast i7-6500 CPU.

I do reduce the polyphony to 16-24 for many patches, as I do not need larger polyphony for the songs and way i play. This may help you as well.


#11

Thank you very much for the insight @adderoo. Very similar setup indeed so there’s definitely hope.
I realize I should update my Spectrasonics products as they were installed a long time ago. I will report back once I’ve done that (but it could take some time).


#12

guess updating will never hurt indeed. Having all the Steam files on an SSD drive and reducing the polyphony to 16 or so did greatly help me using Omnisphere & Keyscape patches live


#13

It seems I’m late to the party. This looks similar to my issue:


#14

I have just realized that if I save a song while the plugin’s GUI is open, once you recall the song, it opens up the GUI right away.
…and if I do this for Omnisphere/Keyscape, then it fixes the sounds not loading up at startup.

Not a great workaround as it takes 8s to switch songs, but this may give some hints on why we have the problem.


#15

And here is another observation…
If I enter Plugin Parameters and switch from Plugin Snapshot 1 to Plugin Snapshot 2 (which is default init sound in Omnisphere) and back again to Plugin Snapshot 1, then it correctly triggers the sounds loading.
…and it is really quick.

After reading the previously linked thread, I have no doubt Keyscape is at fault here, but how could I automatize this plugin snapshot trick? This would quickly solve my issue!


#16

Try this binding combo shown on example, ( I used blooo64 1) route to the plugin GUI not the MIDI In

This should apply to Song States, Racks and Rack States as well.

Dave


#17

Thank you so much @dave_dore and congratulations: you have just fixed Keyscape outside the “Pre-Load” mode.

And by the way, you have opened up new doors for me… again!

Thanks to @hitektodd too! Your thread from two years ago helped me… and maybe Dave’s solution above will be useful to you as well.


#18

Pardon me for soliloquizing again…

So I have updated all my Omnisphere and Keyscape products.
It did not solve the sound loading and I still have to use the change preset trick.
By reading other posts from 2 years ago. I see this is how other people solved it already. Sorry for the noise, I did not see those posts at first.

Now I have very disturbing crackles and glitches with Keyscape, especially with the LA Custom C7 Piano sound. They begin to start when I play four or five notes at the same time.
I’ve tried every combination I could imagine of options in the Audio Engine until, and again pardon me for the constant comparison, I tried yet again this sound in VIP: as always for me, it is working flawlessly in this environment.

So back into Cantabile, I open up the Monitor Window and I see Time Loads of 200 or even 450% when I play Keyscape. Very frustrating and absolutely no reasons for that I/O wise: everything is loaded up in RAM. I’m even using the thinned version of the samples.

And here is the strangest observation: if I open VIP as a VST inside Cantabile, hosting itself Keyscape… all my crackling issues disappear magically and time loads are back under 10% when playing the piano sound.

Very, very counter-intuitive.
I don’t know if Brad will be able to use this information but I thought it was worth sharing.