Play button (In Transport) needs two presses to start?

On my controller I have assigned mode as MMC and the transport buttons work, however the Play button requires two presses to activate the play in C3. At this stage I only have the Stop and Play buttons assigned. The Pause does not work, and the recording seems to need a “Recording Set”? This sort of takes away from the spontaneity a bit? You suddenly want to start recording something you are playing and you have to stop, set up this “Recording” set, and then you can go on???

Any ideas on why this is?

haha nice to see everyone has no issues with this (18 views, no comments)…that being the case some further advice would be appreciated :wink:

Hey Dennis,

What controller are you using and could you post your bindings so we can see what you are using. Also I’m curious if you have tried a MIDI monitor to see what it sees coming in from the controller?


Hi Dave, sorry for late response - got called away.

It’s an Arturia Keylab MK II - I am using MIDI learn for setting the binding under MMC Mode - (MIDI Machine Mode) it’s the only mode on the keylab that transmits the transport controls out. Apart from DAW mode and I’m not running DAW mode because it’s not seen by C3.

So its’ the MMC start and Stop codes…on the Keylab the play button is also marked pause so I suspect this may be where the issue lies, not sure though.

Here is what is getting sent when I press the play button (on the Keylab).
F0 7F 7F 06 02 F7 on first press
F0 7F 7F 06 09 F7 on second. Which are both the correct three data bytes for play and pause under MMC. So I think it is more that. And these are not editable on the keylab. So I’ll juts need to live with needing to press twice to start (depending on what “cycle” the switch is on :slight_smile:

Hi Dennis,

If you are getting Play and Pause from the same keylab MMC button you could use 2 Cantabile bindings so that both the play and pause messages are seen as Play by the Cantabile transport. That should stop the 2 press stuff I would hope.

Regarding the recording set issue. This feature has a switch in the options fir recordings at the top of the pane to set it to automatically assign a new recording set with each new song but it doesn’t take until you save the song with a name.

If that box is unchecked you have manually create a new recording set from the recordings pane hamburger menu.


1 Like

Thanks Dave, iirc I tried that trick, but I’ll double check it.

With the record all I am after is I hit the record button on the Keylab and C3 just starts recording for me… I’ll try out those controls though and see how it works for me.



Usually creating a recording set should only really need to be done once:

  • If you have the “Automatically create a new recording set for each song” option turned off, you create the recording set once, and then it’ll always be there no matter what song you have open.
  • if you have the “Automatically…” option turned on, Cantabile will automatically create the recording set so long as the song file has been saved an has a file name.

As for the buttons needing to be pressed twice, I’m really not sure. Perhaps try enabling binding logging to get some insight. (Options -> Diagnostics -> Log Bindings).


1 Like

FWIW I ran into this as well on my Keylab MKIIs. Nothing a binding can’t fix. I do exactly the same as what Dave D suggested.


Perfect Dave - I actually had the same controller button mapped but one set to Play and the other to Pause. Setting both to Play did the trick, thanks!!

1 Like

Thanks, I just set mine to mirror that image. That should do it I think.

Haha, it worked, but the Recording button from the Keylab needs to be pressed twice to start the recording. Tried the same trick as the Play but it didn’t work. It’s no biggie though… I’d only be using the record function in the studio not on stage.

1 Like