Persnickety Issue

I’ve got a program killer of an issue that is unacceptable for live performance. I don’t know what or why it is happening, but it is happening. I was at practice today, and I had to restart my system 6x to get Cantibile to work – and I don’t even know if it is a problem w/ the app. I just know that it keeps happening.

All of a sudden, midi dies, and there’s no getting it back – save for restarting the laptop (on which the synths are produced via VST). The program appears to be fine, but there is no read coming off the keys after whatever happens happens. The app operates fine, but there’s nothing coming into it.

I’ve 3 M-Audio controllers (49/61/88) and a Alesis Vortex connected via USB and a 3.0 hub.

I try to hit the midi clear/stop. I restart Cantibile itself. Nothing works. I have to restart the computer to get everything operating again. I cannot do that in a live gig.

I’m not blaming Cantibile (3.0). It didn’t start happening until I added the 3rd M-Audio piece … but … this issue must be resolved … so any thoughts towards resolution are appreciated.

I am going to do the simple stuff – replace cords etc … and see if the weakest link in the chain might be the thing that creates the problem, but … why does ALL MIDI GO DEAD and will not come back?

Any thoughts? The issue makes the app untrustworthy – even should it not be the app that is the problem.

Thanks in advance!



I wouldn’t be surprised if it were a bad USB lead/socket. Those USB sockets in keyboards are often flaky/loose in my experience, which is why I stick with good old 1980s style DIN MIDI connections where possible.

When you lose MIDI, have you tried simply unplugging and re-inserting the USB cables? Cantabile should be able to re-establish a connection. I’ve occasionally had this kind of MIDI loss situation, and usually a quick unplug does the trick without the need for a reboot or Cantabile restart.


So it might just be unplugging/plugging in the usb cables again?

I can try that … which is why I suspected it was cabling. Yet – why did it all going down in the app? That’s just a bit of a “huh”? Shouldn’t only the device “turn off”?

Hi Kevin,

Out of curiosity, what OS are you running and are you using the generic windows MIDI drivers for the M-Audio keyboards or the ones from the M-Audio Site? A lot of USB Hub problems stem from drivers.



All info is good info.

Windows 10.

Windows drivers. Only.

I didn’t even know there might be M-Audio drivers to midi controllers.

I’m not sure with Win 10, there were with win 7 and 8 for my Axiom and my Oxygen. I’ll see what they say about win 10. Windows 10 recently did a major update that threw a few systems out of whack I saw from other posts on the site. Might be related, any ones guess…

checked the site, all their stuff is class compliant so windows provides the drivers for the keyboards and your hub.

Thank you, Dave. From my heart, I appreciate that check on that for me. I’ve got to fix it, still, but your check on that matter contributes towards the solve.

Computers, with their intertwine of signal paths and complex technology and devices, almost gets a by … but for then something breaks and the WTF occurs.

I liken this to having cable TV (which works) and keyboard synths (which works).

… as my reliance on future technology is currently experiencing a problem I don’t yet know how to solve.

I’ve never had anything but nightmares with Windows and USB controllers and interfaces, both driver-wise and physically. I know this doesn’t help you right now but I’m with Neil; I run MIDI into a merger and into my interface so the only USB connection is that single one. That set-up is rock solid for me. Anyway, I would try and make sure all you drivers are as up to date as possible but you might have some physical connection issues- jiggle everything to see if you can make your system go nuts! :wink:

1 Like

I’ve got a USB 3.0 Anker hub. It’s got a dozen ports running into it and is built like a tank. But I’m beginning to believe that the reason Cantabile is losing the midi is not because of the app, but because the hub locks up. That’s why hitting the midi emergency button or restarting the program doesn’t get it back. It’s gone at the hub, so nothing is getting through FOR Cantabile to see. Once I restart my computer, communication to the hub is restored. I’ve already reconfigured the hub, and I’m going to see if the system locks up again. If it does, I’ll unplug the hub and restart that to see if it kicks everything back to normal. I think, you’re right, Fred. It’s probably some physical connection issues.

Well, I will throw in my two MIDI nightmares-turned-real stories to add to the things to check.

One time an Nvidia driver made all MIDI in/out disappear. I had to reinstall the driver in “Custom” mode, with the option to install a fresh installation checked. So, it was the video card of all things!

Another, I recently got a MOTU MIDI Express XT - their best MIDI interface. I found out that even the “black” USB ports on my computer were ACTUALLY going to the same USB3 hub internally, not to a separate USB2 hub. Well, it turns out the MIDI Express XT hates USB3, and would freeze up after a few dozen notes played and then spit out a ton of MIDI data at once (the infamous “MIDI Logjam effect”), so I had to buy a cheap USB2 external hub to act as a go-between. Now everything works perfectly.

You would think MIDI being such an old standard that nothing could break it. Well… as you’ve discovered!


1 Like

The non-dedicated option of VST via PC holds amazing horizons, but the landscape is littered with landmines. I loaded Gimp onto my laptop, and for reasons unknown – this is not but two hours ago, when I launched the program, it sent the USB device into a feedback loop, which kept sequentially opening the SSD USB drives I had attached to the hub (there are 3, including the drive that has most of the VSTs).

Why? No clue –

– but it DID clue me into where my real issue may lie … as Fred intimated above: Hardware issue.

1 Like

I had the same problem with a MIDI Express 128 and it took ages to figure it out, and rubbishes the claim that USB3 is fully backwards compatible with USB2. Fortunately I have a mix of USB2 and USB3 ports on the main computer, so just had to find a combination that worked where I could get the MIDI Express into a USB2 port. From memory, I also had problem with my Beiko wireless USB unit. That also had to go into a USB2 port.

And on my new gig PC building I have seen yet more strange behaviour. It is all USB3 and I also have a powered USB3 hub to expand the number of ports. I have a USB hard drive I have all of the programs to be installed on. If I plug it into the powered hub, it just goes through a constant connect/disconnect loop. If I plug it straight into the computer, it works fine, but the wireless mouse I am using then works intermittently.

1 Like

I brought the 3.0 Anker hub upstairs (from the practice space) to fool with it. I have experienced the exact connect/disconnect you mention. On occasion, windows for the connected SSDs keep opening … repeatedly. I have to unplug the hub and then plug it back in to reset it, and stop the behavior. Not quite the stability I’m looking for when playing out live.

1 Like

Fred and Neil… sage advice!

Don’t forget to disable USB sleep and power management (power save) mode in windows as it indicates in Chapter 4 and 5 of Glitch free. This may be one of the issues with disconnect.

1 Like

I will double check that. Good advice. I think I did already, but Windows updates later – it could have reset itself. Thanks!

I’m saddened to report that the hub was not the issue, as I originally thought. Nowhere in last nights frustrating practice did it disconnect, and yet I had nothing but trouble with Cantabile and the rig.

There are two behaviors exhibited.

One is the aforementioned issue where ALL MIDI GOES DEAD (and in further qualifier) in Cantabile. The hub lights remained on, and I could check the connected drives just fine. This requires a restart of the computer to correct. Curiously, this condition occurs with all the keys working fine up until the lock up.

The second issue is even more persnickety than the first.

On certain projects (mostly with Kontact 5), Cantabile SEES THE MIDI, but nothing happens. The green light says, “Oh yeah, you’re playing something, and I see it.”

I also discovered, with this behavior, that if I turn off one of the keyboards (I’ve 3 M-Audio Keystations in 49/61/88) in Cantabile, either the K61 or the K88, the other starts working. It’s when they’re both being used (and the 88 key is connected to Kontact 5), that the either/or occurs and one won’t play.

This led me to think, “Okay, maybe it’s because I’m using USB connections on both.” So I experimented.

I got my Midi hub out, and I connected the 88 key through it via midi. Then I went into Cantabile, and chose that midi port as the input for the program, and unchecked the USB driver.

NOTHING CHANGED. The behavior remained EXACTLY the same. This also occurred when I selected BOTH the USB and the Midi port as inputs. Cantabile said, “Oh yeah, I see that you’re playing something, but I’m not telling the VST.” (I actually don’t know if that’s the problem, it’s a speculation."

I’ve also deleted the VST and reloaded it.

Basically, it looks like a bind between the 61 and 88 key devices, but I was very surprised when routing via midi failed to cure the problem.

The issue cost me 45 minutes of valuable practice time last night w/ all the restarts and failures. Not good.

I’m going to route all 3 via midi as was suggested, but the USB drivers have to remain on the system as the keyboards are powered via the USB ports.

This must be fixed. Any thoughts/suggestions/experiments (in addition to what has been kindly offered) is warmly appreciated.

It should be working. Everything (all the keyboards, the USB hub etc…) are only a few months old.

It is not.

I use external USB power adapters to do this. That way you can get the drivers off your system. Also, your laptop isn’t dealing with the power drain of the hub and your keyboards. I wonder if that is an issue? I currently have a power strip with 6 standard 3 prong AC plugs ad four USB connections- powers everything.

BTW you shouldn’t need the drivers installed just to provide power.

That is an excellent suggestion. I could also just attach another hub and not connect it to the system. I’ve got some older powered 2.0 hubs that are just sitting around collecting dust. That would be a single plug source solution. Then we can see if coming through separate midi ports will provide conflict-free connections. Thanks Fred! I’ll experiment w/ that.

1 Like

Status update:

As with tangled fishing line, multi-layered issues can take a while to unravel. The second issue above has been resolved, and hopefully, in doing so, progress was made on the first issue.

I did the following (as advised):

  • Disconnected two of the three Keystations from the usb hub going to the computer. The 49 key does not have a midi port. I power them via USB and a wall wart.
  • Ported the larger two through a midi hub, which was then connect via single usb 2.0 to the 3.0 hub.
  • Disabled the commensurate usb connections in Cantabile on the midi port options

The initial experiment yielded no change. Cantabile was still seeing midi activity, but nothing was coming out of the Kontact 5 – and suddenly a light bulb went off. This is an American euphemism for the idea striking me (for those not familiar w/ the cultural phraseology).

I’d done a recent update to my Native Instruments programs, and the thought occurred to me to check the synths themselves to see if they’d been “reinitialized”. Sure enough, that was it. I had to go through every NI VST and reroute the settings to where I’d originally had them. Once done, they worked as designed.

At the end of the day, it was an NI issue that caused the midi to be recognized by Cantabile, but not communicated to the NI VSTs due to a re-initialization of the midi routing on the updated VSTs themselves.

That internal conflict, in some way, MAY have led to the situation where midi ceases to function and a full restart is required … or …

… it could be something else … like routing via USB vs. MIDI.

In a song I worked on last night, Cantabile locked up – and this was one of the songs where everything was working fine (there were no NI VSTs employed) … until it locked.

Once I’d switch over to the midi hub (versus the USB) this morning, I worked with Cantabile – resetting the NI VSTs on each song – for well over an hour. It was rock solid. Zero glitches via MIDI.

Because I’m a curious itch, I’m going to flip back and forth between employing the USB hub and/or the MIDI hub and see if I can get the error to replicate. I’ll post my findings up in a later report.

But at least one issue solved, and back to the lab on the other one.

Thanks to all for the treasured input and assistance!


1 Like