Page faults and Omnisphere 2

Hello everyone !

I use a lot omnisphere 2 in my Cantabile 3 setup as pad layered with my main pianos , but it seems that the page faults are pretty high with it (often above 2000 page faults) .
If I disable omnisphere , and simply play any of my piano sounds (Ivory , Ravenscroft UVI , Hammersmith in Kontakt 5 ) , even if they are pretty demading plugins , the page faults count stays under 5 !
So what ? Is omnisphere 2 not really well optimized ? Is there a way to set it up so that the page faults don’t get so high ?
And (you never know) , is it just me ? Or do you observe the same behaviour with omnisphere 2 ?

Don’t know if it’s important , but the strings sound I use most otfen in omnisphere 2 is “Adagio transparent strings warm”…

Thanks for reading !

How much RAM have you got, and are you running other stuff on the machine?

Neil

Hi Neil !

My Laptop is a core I7 , with 16 GB RAM , and omnisphere data is installed in my 512 GB SSD , nothing else is running on the laptop when I use cantabile 3…
It’s really only omnisphere that give me these page faults…Any other plugin don’t…:confused:

Strange - that’s the same spec as my setup, yet my page fault count tends to stay on 1 or 2, even in songs with several instances of Omnisphere.

Neil

Hi again !
I tried the same setup in Cantabile 2 (just my my pianos and omnisphere 2) , and just like you described , my page faults tends to stay on 1 or 2 as well …
Did I forget something in Cantabile 3 ? Any parameter in the options ?

@HAIKINE_Alexandre I am experiencing the exact same issue in both C2 & C3. When running Omnisphere or Kontakt I see page faults all over the board, sometimes in the thousands. However when running Ivory my page faults never go higher than 2.

  • 2.8 GHz Intel i7-4810MQ Processor (4 cores, 8 threads, 6MB cache)
  • 32GB HYPERX DDR3 1600 RAM
  • Primary Drive (OS): 512GB mSATA SSD (Samsung 850 EVO 6Gb/s)
  • Second Drive (Audio): 1TB mSATA SSD (Samsung 850 EVO 6Gb/s)
  • Third Drive (Audio): 1TB mSATA SSD (Samsung 850 EVO 6Gb/s)
  • Second & Third drives are spanned for 2TB total for all sample libraries
  • Operating System: Windows 8.1
  • C3 Build 3160

I’m sorry for you , @mrheiser , but I’m kind of glad to see I’m not the only one facing that issue…(and sorry for the possible grammar/vocabulary mistakes …I’m french)

I still don’t know about omnisphere , but in Kontakt , did you try to disable multiprocessor support (within Kontakt itself ,Options/engine/mutiprocessor support ) , to let Cantabile (the host) handling the Multicores ?

Hi All,

Just a quick note about page faults…

By themselves page faults don’t necessarily indicate a problem, but they can be a clue to a problem. Page faulting it a perfectly normal part of Window’s memory management. The problem is typically determining whether the page faults are on the audio thread (bad) or not (fine).

Firstly, make sure you’ve closed the plugins GUI. If the GUI is page faulting that won’t be on the audio thread and not impact performance. You can also try minimizing Cantabile’s main window to make sure Cantabile’s screen redrawing isn’t impacting things. (you’ll need to check page faults in task manager)

Secondly, you should look for correlations between playing notes and page faults - this is a better indicator of issues - but still not definitive.

Finally, the clearest indicator of problems is when page faults spike at the same time as Cantabile’s load meter and/or and the same time as an audio glitch or drop out.

I’ve tried several times to understand Windows’ API’s for collecting hard page faults on a per-thread basis but it’s anything but trivial. If I ever figure that out and it doesn’t impact performance it’d be great to be able to show the number of hard page faults on just audio engine threads.

Brad

Thank you for these explanations , Brad , but how do you understand ,that for similars setup , with the same plugins , we all have so different results ? And different results (for my case) between cantabile 2 and cantabile 3…
I really had no page faults with omnisphere 2 in cantabile 2 …In cantabile 3 , as soon as I play a sound with omnisphere , the page faults hits numbers above 3000 …:confused:

(The GUI is always closed when I play )

And for Neil ,for example

@HAIKINE_Alexandre

I never pretend to be able to explain Windows memory management :slight_smile:

Quick question: I don’t think you mentioned which version of Windows you’re running? Same as Neil and mrheiser?

Other than that, I can’t think of anything off hand that would cause Cantabile 3 to invoke more page faults than Cantabile 2. Besides the prevent page faults option (which I generally don’t recommend) I mostly just leave memory management up to Windows. There are no other settings in Cantabile that I can think of that might affect this.

Have you contacted Spectasonics about this? I’d be interested to hear what they suggest.

Brad

I disabled multiprocessor support within Kontakt but I still have the same issue.

@Neil_Durant

Neil, what does your system configuration look like? I am running Windows 8.1 and all the latest software versions … Cantabile 3 Build 3160, Omnisphere 2, Komplete 10, Ivory II, EastWest Complete Composers Collection 4 PRO. So far only 2 software packages give me good results, less than 2 page faults, and those are Ivory II and FM8. The laptop specs are listed out earlier in this thread. I bought the laptop from PC Audio Labs and they custom configured the OS to be used specifically with DAW software. Also I am using a MOTU UltraLite-mk3 Hybrid audio processor interface connected by a 3 ft. gold plated USB cable. I’ve changed my audio engine config buffer size from 128 samples to 256 samples @ 48kHz. After this change I saw the Cantabile load level come down quite a bit however the page faults are still quite high while using Kontakt, Omnisphere 2 and EastWest Hollywood Strings. The sound output quality is extremely high and I am more than pleased with what I hear. Being a systems engineering guy I guess the part that has me baffled is the technical aspects and why some people see very low page faults and others like me are seeing high page faults in some but not all VSTi’s. I appreciate all the input on this topic. Thanks.

Matt

Hi Matt,

I don’t have any answers for this, but just throwing out some thoughts/questions:

  1. What happens if you disable Cantabile’s multi-core support - seriously doubt it’ll help, but stranger things have happened.
  2. When your song is fully loaded up - what is the total memory usage of your system. eg: do you have a lot of other stuff loaded/running at the same time (including programs other than Cantabile)
  3. The plugins where you’re having trouble - I think these all have their own buffer sizes (typically the buffers used to stream from disk). Does changing these have any impact?
  4. Is this high page fault count continuous while playing, or does it just spike when first playing, or is it a periodic thing - every N seconds or similar?
  5. Are you using jBridge for any of these plugins?

Brad

I tested something you may (or may not) find interesting @brad
I tried omnisphere 2 in 32Bits with JBridge in Cantabile 3 64bits , and doing that , the page faults stay very low (not more than 1or 2) compared to regular omnisphere 2 (x64)…
Could it be a hint for you , Brad ?

@brad

  1. What happens if you disable Cantabile’s multi-core support - seriously doubt it’ll help, but stranger things have happened.
  • Changing this setting made no difference

When your song is fully loaded up - what is the total memory usage of your system. eg: do you have a lot of other stuff loaded/running at the same time (including programs other than Cantabile)

  • Just loading one instance of Omnisphere 2 Adagio Strings total system memory usage is around 1.1GB. My laptop has a total of 32GB HYPERX DDR3 RAM. Only Cantabile 3 running.

The plugins where you’re having trouble - I think these all have their own buffer sizes (typically the buffers used to stream from disk). Does changing these have any impact?

  • I haven’t had a chance to inspect this but I will tonight.

Is this high page fault count continuous while playing, or does it just spike when first playing, or is it a periodic thing - every N seconds or similar?

  • It is continuous

Are you using jBridge for any of these plugins?

  • I don’t even have jBridge installed

Hi @HAIKINE_Alexandre

Yes, that makes sense because Omnisphere is no longer in-process to Cantabile - it will be running in its own separate process (AuxHost). Cantabile’s page fault counter only reports on page faults in-process to Cantabile.

It would be interesting to see if the AuxHost process is also reporting excessive page faults - you’d need to use task manager or something equivalent to see those.

Brad

Hi @mrheiser,

OK. I’m going to contact Spectrasonics about this see if they have any clues.

Brad

Thanks Brad! I really appreciate it.

Hi Matt,

Sorry it took a while to get back to you on this. My system is a Gigabyte Brix GB-BXi7-4770R pro Core I7 (3.2GHz), with 1TB SSD, 16GB RAM, running Windows 10 Home (x64). I run a load of plugins - Ivory II, Omnisphere 2, M-Tron Pro, ME80, Komplete 9 (Kontakt, Absynth etc), OP-X Pro-II, Synth1, VB3, XPand2!, Wavestation, M1, Diva, ImpOSCar2, Minimonsta, ProSoloVst, SampleTank2. Running a MOTU UltraLite-mk3 Hybrid, same as you, into a USB3 socket, and MOTU MicroLite into a USB3 socket. Buffer size 192 samples @ 44.1kHz (so a difference there).

In my Cantabile options I have:

  • Number of audio threads: Automatic (4)
  • Multi-processor mode: Compatible
  • Prevent memory paging: Disabled
  • Sample rate conversion quality: Good
  • Double precision audio: Disabled

in Kontakt I have multiprocessor support disabled (I’ve had problems with it enabled in the past, though haven’t tried enabling it with Cantabile 3). CPU overload protection disabled.

One thing I did before using this platform for Cantabile is follow as many online guides as possible on setting up Windows machines for audio use, and spent a lot of time carefully disabling various services. I have wifi/Bluetooth disabled on this machine, as I see big load spikes when they are enabled.

There are a few optimisations you can do with Ivory. If I disable sympathetic resonance, the Cantabile load drops dramatically. So I have it disabled for live use, except for one or two tracks which have piano in complete isolation, where there’s a chance the difference might be noticeable). Also I run Ivory with release samples disabled, partly because I’m not all that bothered about the effect it provides, and partly because I notice I get page faults with them enabled. Not that page faults concern me directly, but clearly if Ivory is having to go to disk to load release samples that I don’t particularly care about, that’s best avoided. So you might try tweaking those and see if your system improves.

Neil

1 Like