Only a single plugin route input? Can't sidechain

Hello guys. I am trying to setup a sidechain into G8 Dynamic Gate plug-in; I activate the sidechain inside the plug in but in Cantabile lite there is no extra plug-in input appearing…

Please see the pic.

How do i fix this? I’ve tried other plug-ins as well but Cantabile only shows 1 input to each plug-in even though some support more.

Kind regards

Hi Tnf,

I noticed this on some of my compressor plugins too. I think that @brad will have to help us out on this question, I would like to know more too.


Cantabile only automatically exposes the main stereo ports of a plugin; you’ll have to connect the external sidechain port manually.

  • right-click the plugin, select “Audio Ports”

  • click “Add” - select “Stereo Input Port” (for a stereo plugin, the Side-Chain is usually also stereo, otherwise select “Mono Input Port”) - call that port “Sidechain” or “SC” for convenience…

  • Now double-click each of the still-unassigned left and right channels to assign them to the correct plugin input:

  • Now you need to click the “Add” button and select the correct assignment for the left and right sidechain input channel at the bottom.

  • Once you’ve done this, the “Edit Ports” dialog should look similar to this:
    (Unfortunately, in FabFilter plugins both the left and the right channel of a stereo port are named the same, so this looks kinda wierd…)

  • Now you have an input port in Cantabile that you can route your sidechain input to:
    In this setup, the output of Addictive Keys triggers the side chain of the compressor (which is not connected to any real input yet - just a quick demo…), once “external sidechain” is activated within Pro-C




Hello and thank for the reply. I’ve already seen this post before, and they issue is that no Ports from the plug-ins are shown! Only the once from Voicemeteer Banana that i use (aka IN#1 to IN#5). I’ve even tried the same Fabfilter plug-in and they don’t show! I’ve tried having the plug-in open, sidechain enabled etc, several different ways but it will not show any plug-in input in the Ports list!

It sounds like your Cantabile installation or your G8 installation setup is somewhat messed up. I’ve just done the following:

  • Installed G8 (I can demo it for 14 days from my PluginAlliance account)
  • “downgraded” my Cantabile instance to Cantabile lite
  • Created a simple song with G8 in it

In this song, G8 shows with two stereo inputs even without the need to manually create the sidechain ports:

Selecting Stereo In 2 as a target achieves exactly the desired behavior: it allows to drive the external sidechain from any audio source in Cantabile.

Not sure what is different between your installation and mine…



OK, quick update now that I’ve installed Cantabile’s latest build on my desktop machine: here, Cantabile will only automatically connect the first stereo in - this is the Audio ports dialog window directly after inserting G8 in a song:


But, using the steps described above, I simply add the sidechain port and assign it to the plugin ports 3 and 4. Now the Audio Ports dialog looks like this:


Can you get to this state in your setup?

Now, I connect a media player to the “Stereo In” input and a synth to the “SC” input and play a song in the media player. In G8, I simply set “External Sidechain”, no need for expert settings. Now I pull up the threshold and can instantly control the output of the media player by playing notes on my synth:


OK, Cantabile Lite doesn’t have any media players, but the same thing works when feeding G8 with a synth.

Can you post a screenshot of what your audio ports dialog looks like for G8?



1 Like

Hello. The plug-in is fine, i’ve tried it in a different DAW and sidechain works as expected. I am using Cantabile 3 build 3543. Tried both x64 and x32. Tried both lite and performer versions. Tried uninstalling and re-installing it, but it seemed to remember all my settings. I made a new song. I deleted all the ports, changed device. Same thing. I’m on Win10 v1803. No idea why it is not detecting it the extra plug-in ports.

Wait. I think i’ve found it. I didn’t saw you made a new post directly after that. IF you right click on the plug-in there is an option “Audio Ports”. I was going in the settings menu for “Ports”, did they moved it here, that’s why i couldn’t get to them before? LOL I think i should be fine now:P Let me test it:)

Update: All working perfectly, but had to change to S.A.R. (Synchronous Audio Router) instead of Voicemeeter Banana with my 2i2 as it was giving me crackles with inserts enabled which made it unusable.

Hmm, that‘s exactly what I posted in my very first reply…

Sorry, i seemed to missed that line:p You should make it BOLT to avoid this :stuck_out_tongue:

You might want to read the post I wrote in great detail including pictures - instead of blaming me for your skipping over useful information :face_with_symbols_over_mouth:

1 Like