Omnisphere 2 Lost Song Settings


#1

I am having a problem with Omnisphere 2 where, for no obvious reason, all of the patch settings are lost for a Cantabile song.

Order of events:
We were doing a quick run through right before a short live set.

  1. I loaded Cantabile
  2. Loaded setlist with 3 songs set to Pre-load
  3. The first song has an Omnisphere plugin
  4. a) (no rack)
    
  5. b) layered multi patch (this isn't stored as a saved preset of omnisphere, I just customized it for the song in the song through the plugins interface launched from Cantabile)
    
  6. c) Preset Model is Entire Plugin Snapshots/Forward to Plugin
    
  7. ran through the set, and all was fine
  8. I needed to adjust something on a massive plugin in the 3rd song, and Cantabile crashed (no errors, just disappeared).
  9. Restarted Cantabile, and the setlist loaded without error, tried to edit massive again, and it crashed in the same manner…I decided to leave well enough alone.
  10. Went back to run the set again and no sound was coming from Omnisphere on the first song, tried to open to rack to confirm my fear that I had lost my settings, and it crash Cantabile (same as above).
  11. Restarted laptop
  12. Started Cantabile
  13. Still no sound from omnisphere
  14. Launched the plugin interface through Cantabile
  15. Everything is now set to the omnishphere default blank (none of my layers and settings were present)!
  16. My Cantabile song files are in dropbox, and I restored the version from the night before when it was working. Still blank (and I verified none of the Cantabile song content had changed via diff on the json content).

I don’t think this is a Cantabile issue specifically because I’ve had this happen with Ableton. I’ve also had it happen with one other song in Cantabile, but I’m getting ready to swear off Omnisphere if I can’t get this locked down.

I think I could probably save the presets in Ominisphere’s interface with a patch specifically for that song so if it lost its crap I could select the preset again, but I hate to maintain yet another set of files for a song.

I don’t understand what is happening. I think the preset model I am using is the most comprehensive, but maybe something is somehow changing in Omnisphere so that the values stored in the snapshot are no longer lining up with what is in Omnisphere? Is there a better choice of preset model for this case?

Everything I need should be saved in the pluginData right? There isn’t anything that is saved externally as I understand it.

Attached ‘restored’ song.Death Was Arrested - Restored.cantabileSong (10.9 KB)


#2

Hi Jonathan,

Do you have multiple instances of Omnisphere/Keyscape loaded? There were some issues with those plugins in this area which I don’t know if they ever resolved them.

However, the issue was the patches appeared in the UI, just no sound - which sounds different to what you’re describing.

When you’ve got a minute I’d be interested to hear if this is related to the preset model you’re using on the plugin. If you can experiment with it for a bit and see if one model works and the other doesn’t. I’ve seen at least one other plugin (Brainstormer) that is incompatible with Cantabile’s entire plugin snapshot preset model - due to bugs in the plugin.

Correct - at least as far as Cantabile is concerned. Theoretically a plugin could save stuff off elsewhere (eg: in a global shared bank or something) but that’s outside the scope of Cantabile.

Brad


#3

To clarify, the plugin was still present, but the patches did NOT appear in the UI. It was as though Omnipsphere was reset to a default state with none of the “instance/state” information that should have been saved. The fact no sound was coming out was just my first indication there was a problem.

The snapshot preset model seems to work with omnisphere most of the time, and in fact this song is one that I’ve loaded/reloaded and used on several occasions.

I do not have keyscape specifically, and this was the only instance of Omnisphere within this set list.

I too have had issues running multiple instances of omnisphere. My issue there is that it seems to have some shared “static” resources that it doesn’t manage properly, evident in that patch sounds will cutoff abruptly after a second.

I’d be glad to try the other preset models, but I don’t know how to recreate the problem I’ve described.


#4

I’ve experiment the same problem.
Reopen a song that was working well. And all patchs were cleared…
Need to recreate a multi in omnispehre.

That’s really ennoying…

Have you found any explanation?