Odd Ivory II behaviour

I’ve discovered some unexpected behaviour with Ivory II. Here are the steps to demonstrate:

  1. Start with an empty song, and create a new rack containing Ivory II x64, and wire it up
  2. Open the Ivory plugin GUI, and confirm it’s the 64-bit version (preferences page)
  3. Save the rack and song
  4. Exit Cantabile
  5. Start Cantabile again and load the above song
  6. Open rack created above, and open the Ivory plugin GUI
  7. Note the jBridge bar at the bottom, and that the preference page shows it’s the 32-bit version!
  8. Double-check the rack file in a text editor, and notice the 64-bit plugin is referenced
  9. Save the rack
  10. Notice now in a text editor, the 32-bit version is now referenced

So it seems for some reason Cantabile is reverting to the 32-bit version after exiting and reloading, and updating the rack file accordingly! What’s going on?! I’ve only seen this happen with Ivory II.


Just to add a bit more information… if I do a full plugin scan in Cantabile, the 64-bit Ivory II plugin is no longer in the list. So maybe Cantabile doesn’t like it for some reason, and is reverting to the 32-bit version when loading a rack including the 64-bit version. This would seem odd, considering I can browse to the plugin, instantiate it, and use it fine - until I save and reload. I’ve tried reinstalling Ivory II, and that doesn’t fix it. Interestingly I can’t reproduce it on my other machine.

Any thoughts, Brad?


Tried reinstall? Copy protection?

I’ve tried reinstalling Ivory - no luck. Copy protection is based on a USB iLok key. If that was failing, then the 32 but one wouldn’t work either. Baffling!

Hi Neil,

This sounds like you’ve got both plugins in your plugin path. Cantabile tries to match plugins by ID and only resorts to the saved plugin path when the ID isn’t known.

If the plugin is in multiple locations Cantabile will just pick one - and it sounds like it’s being a bit dumb in picking the bridged one over the native one.

One thing you could try as a work around is if you have two folders in your VST path (one for x86 and one for x64) - try swapping their order and re-run the scan. The other thing you could try until I get to fixing this is just remove the 32-bit edition from your plugins.json file.

Failing all that, send me a copy of your plugins.json and I’ll check it out. Also perhaps a log file covering a full plugin scan.


Thanks Brad. I thought it may be something like that, so actually tried reversing the order of my 32 and 64 bit plugin paths, and that appeared to make no difference. I then tried temporarily removing the 32-bit Ivory DLL and doing another full scan, and Cantabile didn’t find the 64-bit one, despite it being clearly in one of my two paths. However, by browsing to it I was able to instantiate it etc. But then when I saved, and restarted Cantabile, it complained that it couldn’t find the 32-bit plugin, and Ivory came up with a red indicator. Would removing the 32 bit one from my plugins.json file have any additional effect, above and beyond removing the plugin and rescanning?

I shall send you those files tonight when I get in - perhaps you’ll notice something glaring in there.



Hey Neil,

Still discussing this with Synthogy, but it seems you’re not the only one having this problem.

See this post where @Roland_Robertson suggests a work around by hacking the plugins.cache.json file.