Ivory II doesn't show up in Plugin list

I just purchased Ivory II (American Concert D) and installed it (and LOVE IT!), but it doesn’t show up in my list of VST plugins. I installed the VST into the same folder as my other 64-bit VSTs. It doesn’t even show up in the By Folder or Search for Plugin lists, but I AM able to browse for the plugin manually (selecting the “Ivory VST.dll” file). Also, if I save the Rack after loading the plugin manually, it works fine. But for some reason the plugin still does not appear in my list of available plugins.

Has anyone seen this or a similar problem?

One other note: Ivory II does show up alongside my other plugins in Cakewalk Sonar, which is the only other application that I use.

I don’t know if it’s the best solution, but being nosy like I tend to be, I did find a solution to my problem by manually editing the plugins.json and plugins.cache.json files. An entry existed for the Ivory plugin, but it’s “category” value was “NotAPlugin”. Changing that to “Synth” and guessing appropriate values for the other attributes caused the plugin to show up the next time I loaded Cantabile.

1 Like

Hi Roland,

This sounds like the same problem as @Neil_Durant describes here: Odd Ivory II behaviour. It’s a problem only with the plugin scanner - Cantabile actually loads the plugin fine when manually selected.

Patching the plugins.cache.json file is a clever idea in the meantime.

I’m currently working with Synthogy to try and figure out what’s going on here. I’ll let them know that there are at least two cases of this now. It doesn’t happen for everyone though - Ivory x64 works perfectly fine for me here.

What version of Ivory, Windows and Cantabile are you running?


So it’s not just me!

With that workaround, will it remain ok as long as we don’t do another plugin scan? What about the one at startup?


Hi Neil,

I’d have to check it to be sure, but I think if you make the change in plugins.json and in plugins.cache.json and it should be ok so long as you don’t run a full scan.


It continues to show up as long as I don’t do a full scan. The quick scan on startup does not overwrite my hack. I’ll keep a backup copy of my edits in case I need to re-apply them.

I am using C3 Build 3161, Windows 8.1 on a Surface Pro 3, and Ivory 2.1.2b.

Incidentally, I had another VST scanner nuisance that I “fixed” with a similar edit: I have the Arturua V Collection, and (only) the Jupiter-8 V2 was showing up as an effect instead of an instrument. Editing that attribute in plugins.cache.json solved that as well.

I am willing to post the edits I made to the plugins file (if it’s OK with Brad and if doing so doesn’t violate any licensing agreements!),

I almost forgot. I don’t know if it will help, but I have a MiniDump file from the last Full Scan. I can’t upload here but could send it some other way (e-mail?).

Hi Roland, there’s no issues with sharing those files. You can email the crash dump to contact@cantabilesoftware.com. I’ll look into the Jupiter issue.

I’m having the same issue as Roland with SynthMaster 2. It’s not one which I use often, so no big deal…still, it should show in the list.

I am having the same issue. Tonight I upgraded Ivory II with the latest version 2.1.2. The plugin was showing up on the scan just fine with version 2.0.1.


Thanks - I’ll pass that on.

In the meantime, Synthogy has also asked that you run the Ivory Library Tool and just check it doesn’t show up any problems.

I actually have 3 minidumps that get created when I do a full plugin scan: one for Arturia plugins, one for Korg plugins, and one for the Ivory II plugin. I will send all 3 via e-mail. (When I open the minidumps in VS2015, they all appear to have a similar access violation error, so I’m not sure how helpful they will be, but maybe you will find something.)

I also seem to be having problems where the Ivory II plugin and both the 32-bit (w/ jBridge) and 64-bit versions of the GSi VB3 plugin will fail to load when I open a song. If I delete and re-add any of these plugins, they work fine, but the problem returns after exiting and restarting Cantabile.

I was using Build 3163, but today reverted back to 3160 and did another full plugin scan. There was no difference in the behavior.

I use the newest version of Ivory II all the time here and it always shows up/is found by scans. Cantabile Performer, Win 7. This includes American Concert D (I think the best one, IMHO).

Here IvoryJsonEdits.zip (883 Bytes) are the portions of the plugins.cache.json file pertaining to Ivory II, before and after I manually edited them. Note that I did not know the Plugin ID so I didn’t try to edit that.

This did cause the plugin to appear in the list, but since I’ve had other issues since then, it is possible I have created new problems while solving this one. The usual disclaimers apply, and be sure to make good backups of any files before modifying them.

Hey Guys,

Quick update! I think I’ve finally figured this out (well for Ivory at least). Fix coming soon.



New build 3164 should fix this.

I’m also going to make a few fixes to the way Cantabile selects which plugin to load when there are multiple with the same plugin id, but wanted to get this particular fix out quickly.

Full re-scan should cause Ivory to appear again.

@LeesKeys - I’m not sure if this is the same issue with SynthMaster - give it a go if it doesn’t help send me a log of doing the full scan and I’ll take a look.

For the curious this was caused by a flag in the executable header. Windows 8 introduces a new security measure called “high entropy virtual address randomization” and the new build tools (aka VS2015) turn this flag on by default. Ivory doesn’t like this flag. The Cantabile fix was to turn the flag off + Synthogy are looking into why this is a problem for Ivory.

Oops posted before the upload finished. It’s there now.

Great detective work, Brad!!!

Regarding the future work for selecting which plugin to load when there are multiple with the same plugin ID, will this deal with the case where you have a 32 and 64 bit version of a plugin in your plugin path?


This solved my VST problems, both with Ivory II and the Arturia Jupiter-8 plugin. (Not sure if it was the same issue, but that plugin shows up correctly for me know as well!)

Thanks Brad for being so responsive in investigating this problem.

@Roland_Robertson the Jupiter issue was different - straight out bug in the scanner

@Neil_Durant the new logic for mapping plugin ids is explained here