Odd issue with free VST

I’m using this guy, and it’s a great little free plug.


The issue is this: when it loads the first note played starts at what sounds like C0 and has to glide up to the played pitch. That doesn’t happen when I load it in, say, Sonar. After that, fine.

Any ideas?

Dead capacitor in the VCO???

Works normally here,
Cantabile 3.0 Build 3236
Windows 8.1 32bit

Don’t save a song with the porto on …
He has a bug in his ‘last note’ code where on initialisation the last note = 0.
The porto effect should only come on after an initial ‘note on’ event leaving a ‘real’ note in the last note buffer.
Still … it’s free

Ah, you found the specific bug in his code! Saving the sound without portamento kind of defeats the whole purpose. I could program that exact sound in almost anything else, I suppose, it was just cool to have it there in the little Arp synth. I suppose any time I used it in another program I was opening it up without a specific sound loaded yet.

I’m guessing that Sonar sends ‘an all notes off’ or something which sets his porto properly. However all other hosts I tried has the same issue you found. I’ll try and find a work around for you.

Not fixable. Even switching the porto on off on doesn’t reset the last note buffer. Major oversight - shame as it’s a nice retro synth.

I’ve just been loading it and hitting a key before the set starts. Gnarly but effective. I may replace it though. I don’t know of any other Pro-Soloist vsts… do you?

No fraid not.

Have you tried his Hammond L-122???

Yeah… a lot more “meh” on that one :wink: