Occasionally getting distorted output when using cantabile


#1

Setup information:

OS: Win 7 Home x64
CPU: FX-8300
RAM: 8GB DDR3
Audio card: Asus Xonar DSX PCIe with ASIO 2.0 support and latest drivers.
Microphone: Snowball ICE
Mixer: Voicemeeter Banana (native cmasiopPCIX ASIO driver for ASUS Xonar DSX card as primary device)
Cantabile version: 3. Build 3636 x64
Cantabile Audio Driver: ASIO Voicemeeter Insert Virtual ASIO

What I use cantabile for: I use cantabile to create a vocal chain for vocal output to Twitch Sings, which does not have ASIO support. Between cantabile and VM Banana I get post-effects monitoring, on a very short latency, of my vocals.

Issue: Changing things like buffer sizes in Voicemeeter Virtual inputs causes Cantabile to output heavily distorted, garbled robot like output. Reboot is only solution. Closing cantabile and monitoring without effects provides normal vocal output, but of course without effects, but the problem persists when I fire cantabile back up.

Sometimes this issue is also present on a cold boot but pretty rarely. Maybe once per 40-50 boot ups of my system, or even less.

I have tested to see if a specific VST is responsible, but even with none loaded and audio routing in pre-fader from Voicemeeter Banana and the issue is still there. Load and page faults are low and I’m not overdriving the output. (levels are the same as when it’s working properly)

All power saving features are disabled in Windows and BIOS.

Cantabile works great, very satisfied with it when it’s working. This issue is caused by my actions 99% of the time and I’m wondering if I’m doing something wrong or I have something misconfigured. Would “powering off” cantabile before changing these types of settings prevent this from occurring, or maybe a complete shut down of cantabile while changing sample counts etc in VMB?

I increased my Virtual Input sample counts in VMB from 3072 to 4096 while Cantabile was running and “powered on” because after several hours of use I was getting light pops in my monitors (headphones) even with no audio playing and the mic channel muted in VMB.

Here are some screenshots of what I believe might be pertinent:

Deleted screenshots since I can only insert one per post as a new user apparently.

Actually, after opening the settings in Cantabile several times (which powers off cantabile temporarily) for the screenshots, it happened again. Cycling the power off and on a couple of times and it’s back to normal again, so I’ve basically found my solution. I had never tried cycling the power more than once before, seems doing it a few times is the key here. Would be nice ofc, if this wasn’t an issue to begin with.


#2

I don’t have an immediate answer for you, but this seems to be a persistent/common problem with using VoiceMeeter. I have discussed it with VoiceMeeters developer and made some changes at his suggestion but it doesn’t seemed to have helped much.

@terrybritton any suggestions for @IntrebuloN?

Brad


#3

Nothing to add. Powering off Cantabile’s power button and powering on again a few times till it “sticks” still seems to be the best and only easy solution. At least once it does sync it stays in sync. As I never play around with settings during a show, it doesn’t matter so much. (I stream all of my shows using a similar setup into OBS.)

Terry