"Not built for this platform" error with many 64 bit Plugins


#1

Hi,

I’m running into an issue where about half of the 64-bit plugins that I try to load in Cantabile give me the same error: “the plugin is not built for this platform”. I’m assuming assuming that Cantabile thinks these plugins are 32-bit (I’m on a 64-bit windows tablet and running the 64-bit version of Cantabile).

The only plugins that will load for me are the Native Instruments and Toontrack plugins. I’ve tried to load Neo Soul Keys Studio, Synthmaster and some other 64 bit plugins and I always receive the same “not built for this platform” error.

I tried to re-install those plugins and made sure to only install the 64-bit versions so there is no trace of a 32-bit version on the tablet and still the same error. I’m racking my brains because there are some sounds I really want to be able to use live and they aren’t loading. Very frustrating and starting to make me look around for a different VST host.

Does anyone have any idea how to troubleshoot this issue? Why would some 64-bit plugins load fine and all others give me the same strange error?

Thanks for any help.

-Sean


#2

Hi Sean,

Are you installing VST2 or VST3 or a combination of the two? Cantabile is good to go with VST2 plugins but rejects VST3 until the capability is implemented. Could that be the problem? Or are all the X64 plugins VST2 type already and only some will register with Cantabile? The 32 bit plugins will also registaer and run with the addition of the Jbridge 3rd party app.

Dave


#3

Hi Dave,

Thanks for the response. I’m not really sure how to tell if they are VST2 or VST3, I know Neo Soul Keys Studio is a fairly new product so if VST3 is a newer format the it might be that. I wonder if there is a way to tell what type of VST they are using, I don’t see any mention of that on their website.

Does anyone know if a release date for VST3 compatibility has been announced?

Thanks,
Sean


#4

Hey Sean,

You go to the VST plugin folder that you chose in the Tools>Options>Plugin Options and check the extensions on the plugins in the folder, the VST3 could be there by mistake. The VST2 will have the .dll extension and the VST3 plugins would have the .vst3 extension. These VST3 version plugins are usually installed in the C:\Program Files\Common Files\VST3 folder by the different installers so it’s probably not the problem but bears checking. Do other hosts load them on your system is also a question, I don’t have a tablet so I can’t be sure if that’s got anything to do with it but on Towers and laptops I have never seen problems of this sort in Cantabile 2 or 3. I hope you can get it going but you might need some assistance from the developer @brad, I think he has a Windows tablet too and could give you some first hand help. Best

Dave


#5

Ah ok, that makes it easy. These are all definitely VST2 plugins, they all have .dll extensions. So I guess that rules out that issue. Thanks anyway for your suggestion. I haven’t tried any other hosts on this tablet but the plugins run fine with Cubase on my two other windows machines.
I still find it strange that I can’t use many of my 64-bit VST2 plugins with Cantabile due to this error. I’m going to have to start searching for a different host software at this point unfortunately. Thanks again


#6

Exactly which version of Windows are you using?


#7

Racked - I have Windows 10 Pro v.1511


#8

Most likely reason for this - you’re actually trying to load a mismatched plugin platform. If you’re sure this isn’t the reason, I’ll need to see a debug log. Do this:

  1. Start Cantabile
  2. Run a full plugin scan via Tools -> Scan Plugin Folders (Full)
  3. Reproduce the problem (try to insert a plugin that fails)
  4. From the Tools menu choose Open Settings Folder.
  5. Close Cantabile.

From the folder opened in step 4, send me the files log.txt, log-previous.txt, settings.json and plugins.json and I’ll check it out.

Brad


#9

Brad - Thanks for looking into the issue. I just sent you the log files and settings files to the contact email address. I definitely have the 64 bit plugins installed, I made sure to uncheck the 32-bit versions when I installed on the tablet. The same plugins also work in Cubase 9.0 which doesn’t allow 32-bit plugins. Hopefully the logs will provide helpful info.

Thanks,
Sean


#10

For anybody wondering how this turned out, Brad got me straightened out really quickly. It was my own stupidity, I was running the 32-bit version of Cantabile while assuming it was the 64-bit version, so that explains why my 64-bit plugins didn’t work (duh!). Thanks to Brad and everyone else who chimed in for helping me out.

-Sean


#11

Yep. I’ve done the same thing.