Noobest question ever: need to user Cantabile with 2 USB keyboards

Hello members,
surely i will win the “n00b of the year”'s question. Nonethless i’m quite puzzled and definitely going mad trying to configure this setup.

My computer is the same old stuff: an Acer laptop and a Tascam audio interface. Right…

Up to now i’ve Always used a Nektar LX88 keyboard. No problems ever. Just plugged it in and worked like a charm.
Now i need to have a 2nd manual and, since i am quite happy with the brand, i opted for an LX61 (from Nektar).

And the nightmare begins…

Now i cannot make it work in any way!!! configured MIDI INs separately (the 88 acts as a main key). Used the filter source, filtered on channels… Tried everything!!!

The 88 works as it should (plays and the knobs/sliders work): the 61 doesn’t play anything!

Tried to load both Cubase and Reaper (the other softwares i use at will) and i am able to address both keyboards separately with sounds, splits, layers and so forth

Where do i go wrong??!? Please help a n00b fixing his mind up :slight_smile: .

Thanks a lot to you all!


Hi Davide,
Could you post a screen shot of this page …

The 2 keyboards should have different names and be in this list, if not then the new one must be added using the add function. It should be in the add dialog box to check select after you give it the name of your choice.

1 Like

Hello Dave and first of all, thank You so much for Your prompt reply.

I’m at work now and will send the snap as soon as i will get back home.

Anyway, keyboards are properly mapped and can “see” them both on the dialog box.

Wonder where did i go wrong…


Just to be sure: have you created routes from your second keyboard to anything? Your Main Keyboard usually gets connected automatically; for your secondary one, you’ll need to create routes manually.

If you have a route from your second keyboard to a plugin, you can enable a MIDI monitor to see if any MIDI data is flowing: select the route, then select “View->MIDI Monitor” from the menu.

This may help getting closer to the source of the issue.



Hey Torsten!!! Thanks for writing!

And unfortunately the answer is yes… :frowning: . The 2nd Nektar LX61 is connected and routed. I also tried to bind it to a plugin… Nothing happened :frowning: .

I tried even to change global channels on the keyboards: assigning forcifully MIDI Channel 1 on the 88 and MIDI Channel 2 on the 61. No luck.

What makes me sad is that everything works at first on Cubase and Reaper. No settings at all :frowning: .

Anyway… Will try again some weirdoes and see what will happen.

Meanwhile, thanks a lot to you all!


Firstly, before you even think about getting sound (which is another matter) do you see any MIDI activity lights in Cantabile’s upper “inputs” window when you hit the keys?

If you highlight the keyboard and go to View/Midi Monitor, does it show any incoming data? (You need a fresh midi monitor for each keyboard selected, btw.)

You just might have the keyboard routed to the plugin, but not have the plugin routed to an audio output destination to make it audible (which I have done…)


1 Like

As requested, here’s the screen caption.

I assume it is ok but will gladly wait your comments…


Hi Davide,

Thanks for posting. Everything looks good there so the next question is a repeat of Terry’s inquirie above with an added graphic showing the lights he refers to …

If there is no midi activity at this point then the problem is not ordinary and might require some help from @brad . If there is activity on the suspect board slot then it points to a routing or midi filter problem before you get to or at the plugin slot. One other thing you might try, just to gather more info would be to go to the midi settings page and temporarily assign your new aux board as the “Main Keyboard” while deselecting the known good 88 key controller. If this works then there is likely a midi suppression filtering on your Secondary Keyboard routes. I probably missed something else but I hope this gets you another step along. Please post your findings or solution :smiley:

1 Like

Thanks guys!!! I definitely appreciate your efforts for helping me…

I have a little update! I just reset both keyboard to their defaults settings and deleted all the configurations inside Cantabile.

Cantabile restarted “scratch” and i reconfigured it all again.

Now, maybe it wasn’t that but i also changed the USB port where the 61 is connected to (remember i connected both on the Amazon USB hub at first).

Maybe it was just the first move, or maybe the second… Now when i’m into the monitor windows i can see both keyboards having MIDI activity (green led turning on when striking keys)!!!

Now i’m at work will continue investigating later in the evening.


Being the type of person who always suspects any USB hubs to be a problem, I think the USB hub was the problem. :relaxed:


Thx for your reply Terry.
Well, still at work… Will keep testing as soon as i will get back home.

God i was so puzzled! Hope this configuration will work (and i will leave the hub just for dongles: i have an iLok and an eLicenser too!).

Modern laptops have so few USB ports i needed to use an hub… :frowning: .

Anyway… Will keep you posted…


Ok i am sorry saying but i definitely need Brad’s help.
I tried everything but there’s no chance to make these 2 Nektar keyboards work together.
The 88 assumes the control of everything and despite my desperate tentatives of filtering/binding/re-channeling… No chance to make it work .

Brad plz… HELP!


Hi Davide,

@brad will probably need you to send your song files and setup logs via email. Look under Options>Diagnostics and open the Settings folder to locate logs and setup files (json files). Also, I don’t know if this is it but as I recall each Hardware Midi device has a Device Number, you could check to see if they are the same and if so make sure they are different this must be done on the device not in Cantabile. It’s a long shot but thought I’d mention it. Good Luck !

Ok you probably won’t believe this…

Found the reason why my dual Nektar keyboard setup didn’t work properly.

Root cause was… USB hub PSU failure :frowning: .

Really… Everything was ok. USB was ok, keyboards turned on (remember they get their power from USB) and the dongles were connected and working (both eLicenser and iLok dongles).

Problem was… The PSU for the hub, while working, wasn’t sending the right amount of power.
Switched to a 2 Euros chinese one… WORKS LIKE MAGIC!!! Both keyboards started working back again, the pc is responsive, the dongles work… EVERYTHING is OK!

I just want you to forgive me for bombing. Also i want to thank Brad for this magical piece of software. Nothing wrong on Cantabile side… Just a stoopid PSU problem created all this mess!!! And, again, everything seemed to work since a friend of mine told me to look for a different PSU. This one works!!!

BTW i just bought another one just in case and even the second one works :slight_smile: .

As a confirmation i reconnected the old one… And problems arose again.

Hopefully i will be able to play with both keyboards now… Thanks again to You all guys for your hints :slight_smile: .