Noise Burst on Starting Engine

@brad
I’ve been experiencing an intermittent issue of a burst of noise (loud) lasting about one second when starting the Cantabile engine. Lately the problem occurs much more frequently than before. Always when Cantabile starts and often after making a configuration change (which restarts the engine). When stopping and starting the engine repeatedly i.e. clicking the engine button off, on, off, on, etc., it will only occur on the first start.

It has really become annoying. I need to always remember to turn down my mixer before starting the engine to avoid being startled by the loud noise.

It’s now regularly occurring on two separate machines: laptop (Win 10) and desktop (Win 11);
both C3 and C4 versions of Cantabile and
and with two different sound cards: Native Instruments “Audio Kontrol 1” and Native Instruments “Komplete Audio 6 MK1”.
I am using the most recent drivers for both interfaces.

If I switch to the ASIO4All driver, then the noise does not occur, but the latency with that driver requires a buffer setting of 1024. For the NI interface I am using 44.1KHz and 512 buffer.

The issue does not occur when using the same drivers with the Reaper DAW - it only occurs with Cantabile.

I can’t explain why it is occurring more frequently now. Some Windows update??

Has anyone else experienced anything like this?
When searching the web, I found lots of complaints about the quality of the NI drivers, but nothing mentioning the burst of noise when starting the engine.

I also find it strange that the issue doesn’t occur with Reaper.
@brad, I’ve looked at the Cantabile logs and I don’t notice any errors or warnings. Is there something else I can check?

EDIT: One further thing I thought I should mention, the noise burst from the Audio Kontrol 1, sounds the same as when I turn off the PC, but there is still power to the USB. In that case it also emits loud noise until I disconnect the USB cable.

I’m really trying to avoid purchasing a new interface at this time.

Thank you,

  • David

Not true…I am using 512 on it without problems.
But I don’t know what plugs you are using either.

I would check for an updated driver for the interface, and if not, reload current one.

I meant with my laptop and my sound card I needed to set the buffer to 1024 to avoid pops/clicks.
Corky are you using a NI Komplete Audio 6 Mk1?

Already tried that too.

Thanks!

No, I don’t, but you need to check some NI forums about similar problems, and see if someone else solved it.
But, you seem to have some other issues with your machine, as expressed in other threads here. There are so many things that can happen to cause stress. Many of my problems were computer related. If you are having the clicks and pops, it is usually because the cpu, or memory is being overloaded. Large sample libraries, cpu hogs like Diva, and such can overload your resources. There are things like, what we discussed before, stealth programs running in the background, possibile RAM failure, and even malware. It is hard to diagnose from far away, and typing long questions. Check out NI forums, and other computer musician sites. Some times, the answer may be in a large thread you least expect.

1 Like

Hi @dbrendon,

I’ve not heard of anyone else with this issue so don’t have an answer off hand. Does this happen if when no plugins are loaded (ie: new song, no set list loaded)?

Brad

1 Like

Yes. In fact I made a new cantabile folder, changed the settings so there were no plugins and created a new song and it still happened.
Then I added a single plugin, pianoteq so I could test using asio4all. The noise didn’t occur with that driver.

David,

I had a similar problem while testing a Behringer UMC audio interface. A series of about three spikes, at not too high volume, when Cantabile (and Cubase/Reaper as well) loading. Using the Steinberg UR22C and old M-Audio Firewire, no click, no pop.
This is unrelated to buffer size or sampling frequency. So my guess is a driver-related issue.

2 Likes

OK. When this happens, do Cantabiles output audio level meters light up?

@brad : No the output audio meters don’t move during the noise burst.
Here’s a link to a hand held phone video demonstrating the issue:

New Info: I just tested with a focusrite 8i6 and there is no noise burst.

So it seems to only happen with the combination of NI interfaces and Cantibile. The NI interfaces don’t exhibit a noise burst when used with Reaper.

Any chance you have access to a NI Komplete Audio 6 Mk1 (not the latest generation). It also occurs with the much older NI Audio Kontrol 1.

Thanks,

  • David

Then that definitely sounds like an issue with the audio driver/hardware. If Cantabile isn’t seeing the noise in its level meters then it must be further down the chain somewhere. The fact that the noise lasts longer than a single audio cycle suggests this is not an uninitialized buffer.

One thought… does that audio interface have any channels that you’re not using in Cantabile and haven’t mapped? Perhaps there’s a bug in the driver where unused channels aren’t getting cleared on start up.

Try going to Cantabile -> Tools -> Options -> Audio Ports and making sure every channel on the device is mapped to a channel on a Cantabile output port (create a dummy port if necessary).

That should ensure all buffers are cleared by Cantabile and perhaps stop this problem (just guessing).

Brad

I don’t think it explains why it’s not an issue with Reaper?

I added dummy outs for Out 3 & Out 4, but it still has the same noise burst.

Thank you,

  • David

I hear the same noise burst on my computer when Cantabile’s audio engine starts.

The noise burst immediately after opening a * .cantabileSong file that is set to open automatically for VST instrument files is especially loud.

OS - Windows 10 Pro (latest version)
CPU - AMD Ryzen 5850U
Memory - 32GB
Audio Interface - MOTU microbook IIc(ASIO Driver)
Cantabile lite (latest version)

Hi, and welcome to the forum.

Have you tried using the asio4all driver to see if the issue persists?