No sound except metronome


#1

I haven’t used Cantabile for a couple weeks or so, but it was working fine. I must have inadvertently changed something but I have no idea what that may be or how it might have changed.
The metronome plays just fine. Yet when I hit a key on my keyboard, not only is there no sound, but there is also no movement on any of the meters. When I open up Pianoteq in standalone mode, it plays perfectly. So it’s not the keyboard or the connections to the computer. Any suggestions?


#2

Go to options and check the audio out ports and the MIDI ports. Sometimes they mess up and need reconfigure.


#3

Thanks Dave. I’d done that already. I didn’t see anything that looked off. I have 4 racks, all connected to the main keyboard, each rack with a different vst plug in, and all running out to the main speakers. Now, I freely admit, I don’t understand much about midi, but this looks ok to me.
Now, when I go into Options >Midi Ports, it shows my Kawai VPC1. But when i go into Options>Keyboard & Controls, it only shows onscreen keyboard. I don’t remember what settings showed up there before, but shouldn’t the Kawai also appear? If so, could this indicate the source of the problem, and if so, how do I fix it?


#4

FWIW, I kept poking around a lot of settings under options. On a whim, I clicked the Edit button under Midi Ports. Fortuitous. There, under assignments, I saw “4-Kawai USB MIDI” AND “KAWAI USB MIDI (disconnected).” I don’t know why there were to Kawai USB MIDI choices, why one is preceded by the number 4, and why the other one says “(disconnected).” All of this is a mystery to me, so if someone can explain it that would be fantastic.
The other salient fact, only the disconnected option was checked. I checked the “4-Kawai” option, and got my piano back!


#5

Yea, that what I meant by check the ports for MIDI. This happens usually when the device is plugged into a different USB connector it was last in … glad you’re back!


#6

Wow! Thanks for that explanation. No way I would have anticipated such an issue, but that’s exactly what happened! Isaias flooded our basement, right where my music studio was. So I had to quickly move everything, which meant unplugging everything. No doubt when I reconnected the keyboard to the computer, I used a different usb port.
Should I delete the “disconnected” port from the available Midi ports? Will that cause any other unanticipated consequences?


#7

It will be fine, but try to limit the times you change ports. You can’t remove them in C3. You can only remove the dead ports by using an app like this one, it is for removing the extras if needed. or in the Device Manager by selecting ‘Show Hidden Devices’ and deleting the extras manually.

Ghostbuster


#8

Dave not sure exactly what you’re referring to here, but if you’re talking about devices that Cantabile displays as “disconnected” you can’t delete them because they’re not there. Cantabile is just saying “I used to know about the device that you had mapped but it seems to have disappeared”. If you uncheck it, Cantabile will remove the mapping and the “disconnected” entry will go away.


#9

Hey Brad,

Thanks for that info, I hadn’t noticed but am happy it does. I was referring to this program that removes them from Windows itself. From what I understand the system does keep the devices in a device list that is port specific and this program helps erase any devices from the windows device list that are not plugged up at the time. It is used to solve driver problems when a mouse or other USB device is registered at many USB ports and starts to cause driver problems. Removing the hidden devices corrects it in the examples I read about. Is this overkill?

Cheers.

Dave