New user, issues with audio (only metronome audio plays through speakers) - Cantabile 3 Lite Version, Windows 10

Hello again…lol

I’m having what appears to be a fairly ubiquitous issue on this forum…I cannot get audio to play through my speakers. I’ve looked up several guides for troubleshooting, and these are the steps I have taken.

  1. I am using Asio4ALL, but I do have a Realtek ASIO driver as well…neither one seems to work better than the other but I’ve heard better things about the ASIO4ALL driver so I’m using that one, currently.

  2. Audio ports - I have them set to default (for context, I have standard 3.5mm plugin speakers, plugged into the green “audio out” port on my desktop)
    Out: Main Speakers (Default)
    Left - HD Audio output 1
    Right - HD Audio output 2

  3. My MIDI ports are assigned as:
    in: Onscreen keyboard - Onscreen keyboard
    in: Yamaha P-45 (Default) - Digital Piano-1 (I renamed this one)
    out: External synth - (Not assigned)
    out: Onscreen Keyboard - Onscreen Keyboard

I have followed the “Cantabile 3 Walkthrough” video guide on Youtube, and the speaker says that, after verifying that audio is working via the metronome (my metronome DOES work) to use the onscreen keyboard to play a sound through the VST…this isn’t working for me. My keyboard also only plays through it’s own speakers, not my PC speakers. Here is my route:

When I check “MIDI Monitor” for my P-45 keyboard (which, btw, is connected via USB and I did install the Yamaha USB to MIDI driver), it shows input, and then, when viewing MIDI Monitor for the DD Chorus VST, it also shows input. It’s just not OUTPUTTING. I’ve been trying to fix for hours and I feel like it’s a super simple solution, but can’t seem to find. Can you guys please help!

Thank you!

So after downloading the Brainstormer VST, I was finally able to get sound. Looks like I was using effects instead of instruments? Wow. I knew it was something simple…Since I’ve already made the post, can I get a link to a good guide on VSTs or something? lol.

Thank you all so much.

Two things to try:

  1. on the far right (below the power button) I would change to graphic mode (the icon with the squiggly arrow). The routing is much more intuitive in graphic mode, and the list view more useful for adding additional details when needed. This isn’t necessarily related to your problem, but just a more fruitful way to do routing for many people.

  2. Under Tools>Options>Audio Ports, check that you’ve assigned the ASIO channels that go to the physical out to the “Output Port - Main Speakers”. This might be the issue.

There are plenty of folks here that can help out, so hang in there and ask all the questions you need. Cantabile has a bit of a learning curve, but becomes very straightforward very soon…

EDIT - I see you have found your issue, great! I’d still recommend switching over to graphic mode (1 above) , and use list view only when you need to dive deeper into the details.

1 Like

It really boils down to what you are trying to achieve. There are so many, it really boggles the brain. Here is a recent thread :
Favorite new VST Instruments 2020

Pull up vsts in google, and you will be looking for months. Also check the search engine in this forum. It is a great source for many answers. It has definitely been my friend!

1 Like

Hi @ethereal55 and welcome to the Cantabile/VST rabbit hole, many of us here have been lost down it for years…

Just a couple of things to clarify about VSTs. They come in two main categories. VST effects which are exactly that, Reverbs, Compressors etc and a million other things, some emulations of hardware and others completely esoteric, weird and wonderful. These take a signal from a source, effect it in some way then output the result. This is why you were getting no sound as you were sending a vst effect a midi signal, not an audio one.
The other category is VST instruments. These are the things that take midi input and make sounds. Again, there are a myriad of these in sound creation methods and budget.

I also noticed that you mentioned the sound from the keyboard was only coming out of the speakers on the keyboard. This is going to be the case unless you connect the audio output of the keyboard to the audio input of the computer (via an audio interface) and turn the keyboard’s speakers off…

Welcome though to the forum, there’s lots of very experienced and knowledgeable people here who are happy to help out.



1 Like

Thank you!

Thanks for the reply!

Hey, thanks Toaster/Pierce!

This particular keyboard seems to play through the speakers regardless (it is a lower end keyboard after all). I figured out that as long as I had the VSTs set up correctly, I could turn down the keyboard volume and it would then just play through the PC speakers. Thank you for the help! I’ll be looking to dive more into the world of VSTs soon!

You can check the manual of your keyboard for a “local off” setting. “local off” means that the internal connection between keyboard and sound generation is disconnected and MIDI is only sent to your MIDI output. This kind of setting is pretty useful when you use your keyboard with a DAW for recording, so a lot of keyboards have this setting.

But in a pinch, turning down the sound will do the job if you don’t want to use the speakers in your keyboard at all…



1 Like

Thanks for the help, Torsten!