New user, excited to get started, already stuck!


New user here so please be patient!
Cantabile 3 solo, M-audio Oxygen61, Windows 7 laptop, VSTs.

Planning on using this setup for playing live on stage, using the buttons on the controller to switch between the VST presets (AZR, Mr. Tramp, Emily, etc. So mostly organ and piano type patches).

So far I like how easy it seems to create bindings for my various VST patches. But I am already stuck-- having managed to create three bindings, only one works (i.e. generates its sound). The others do nothing. All the bindings appear to be set up the same:
Input Port - Main Keyboard Ch:16
Controller (No Edge Button) XXX [XXX is the CC]
Target [is the name of the VST]

Why is only one VST patch working when all seem to be configured equal?


I still don’t fully understand but a few questions …

Do you have 3 vsts or 1 vst with 3 patches? The binding you show above does not change program patches on a vsti but does enable or disable processing of the vsti plugin slot on the routing page, so it is likely the reason you are not getting the result you want because all it can do is turn the plugin slot on and off. Please correct me if need be so we can help a little better.



Three separate VSTs, all apparently set up the same in C3, yet only one works in C3. All three work in Reaper, the DAW I have been using. Can’t figure out why only one works. Maybe this is not the best way to set it up? All I want to do is simply switch among the VSTs via the (for now) transport buttons on the controller. For example, the Rewind button gives me my Hammond VST, FFoward button gives me my Wurlitzer, Stop button gives me the Farfisa, Play button gives me the Clavinet, Record button gives a Synth, etc. Later on I will figure out how to modify via the presets within each VST.

As you can tell I’m not a power user LOL.

Set List or previous/next song programming is not going to help me as the bandleader calls out the next song as we’re approaching the end of the current song-- different all the time. So I just need to be able to control my sound library by pressing buttons on the controller, after having previously mapped those buttons to specific VSTs,


So in a nutshell, you just want to toggle different VSTs on and off.


Correct, but rather switch between them. I don’t want to have to turn the current one off first, as a separate step. When I choose the new VST it should automatically disable the current one. Like those cheapo Yamaha or Casio with the buttons “Grand Piano 1,” Rock Organ," “Pipe Organ,” “Accordion,” “Celeste,” “Cymbalom,” etc.


Hey Dem,

It looks to me like you should use the Solo function on each plugin binding. Here is an example of how to do this …

The Routing page looks like this with a route to each plugin from the keyboard and one of them set to Solo Exclusive (the Green “S”)

and on the Bindings page you set up your bindings from the transport buttons like this

with this arrangement it will switch to one or another exclusively when you press each transport button. My transport button choices are just for the example but you get the idea, you just use your own choices.



Thanks!!! I’ll have a chance to try this tomorrow and let you know how it works out!


OK now! Well that got me started. It seems to be working as desired mostly, just a little weirdness if I accidentally press the same (transport) button twice (additionally solos up some other VST instruments.) And since I got so encouraged I started adding a few more VST instruments, bound to some other buttons on the controller, but for these to work, I do have to press them twice.

At least now I know how this needs to be configured in theory and am glad to report (so far) no hanging notes at program changes, which was the main problem I was having with Reaper, the other DAW I had been using.

Tonight’s rehearsal will be a better test; I will try it all in C3, hoping for the best!


C3 performed great at rehearsal, no hanging notes, no glitches.

I made bindings for 6 different VST instruments, each soloed from its (one of the six) transport buttons. The routing display shows the live VST with the lit green big “S.”

If I accidentally press the same button twice, all the VST instruments are played. The display shows not the lit green “S” for each, but smaller white S for each. If I press the button a third time the correct VST instrument is played and displays the lit green “S.” Is this to be expected behavior?


Hi Dem,

Yes, it is expected behavior. If you press the solo once it engages exclusive to the slot you selected and turns green, if you press the same button again it reverts to no solo so all slots play and the S’s are white . If you press any other solo button while they are all white will select that slot as solo exclusive and the S will go green.



Thanks! That confirms that I didn’t do anything wrong setting it up yet.