New Laptop is making me nutz

My “new” laptop is an HP EliteBook 745 G4, 16GB RAM, Win 10 latest updates/BIOS from MS and HP. I work for HPE, it’s a company issued laptop. I’ve upgraded it (yeah, personal funds) with an m.2 500GB drive (C:) and a fast solid state SAS drive (D:). I have a new MOTU 4PRE interface connected via a USB-C to USB 2.0 connector. I’ve run through all of the power settings for USB hubs, background processes, set swap files manually to 32MB on C and 2000MB on D (using Glitch book). Cantabile will run for a while, I can tap keys, sounds comes out as expected. After a few minutes (varies) one or more inputs (sax mic–nothing plugged in or maybe Kurzweil Input, also not plugged in) will indicate in the side Monitor window 90%-100% steady. If I tap keys I may see MIDI traffic indications with Cantabile, but nothing at all comes out of the speakers. I can recreate this with my Komplete Audio 6 (KA6). If I turn off Cantabile’s Audio Engine, wait a few, turn it back on and it works for a while. Right now, MOTU is set at 44.1K, 1024 Samples, Internal clock. Similar settings on KA6. I have a PreSonus 1818 I’ve tried, too but didn’t do much testing. I blamed it’s driver and went to the MOTU.

Using LatencyMon, it looks great (all happy and green) for a bout 2 minutes. All of a sudden the bottom line turns red and goes all the way to the right. That would make me thing something happened with disks or page faults, but I don’t see anything.

I’m usually pretty good at this stuff, so it’s getting my nerves. I have a log.txt with verbose turned on and I don’t see anything at all that looks suspicions. Appreciate any pointers.


Nvidia graphics card perhaps?

I had wonky things going on until I updated the drivers in custom mode and checked the box for a clean install. Even MIDI wouldn’t work right!


No discrete graphics card. AMD CPU/chipset with built in graphics. All the latest drivers and updates.

And what does latencyMon show you?
There is a list that might show you the driver that is responsible for the glitch.

Well, based on the fact that it’s griping about hard pagefaults, I’m investigating and testing random swapfile settings. I’ve manually set the swap file on C: to 2x physical and D: to 5x physical. With PreSonus LAtencyMon has been running over 3 mins. That’s a record. I may be on to something.

1 Like

A new laptop should make you nut, not nutz! :smiley:


I also used to have an Motu interface. It was a micro book. I was never able to get it working nicely with the original drivers.
I replaced them with Asio4all which was working much better. In the end I switched to RME and now everything is fine.

MOTU and Windows don’t have a very good history of playing well together, from what I understand.

I’ve used MTP’s and PCI 424s + 3 x 2408 mk3 on PC for years. Been pretty good.
Its possible that their USB boxes are not as solid. I gave a NI Komplete back to the store as it couldn’t compete at low latency with an old M-Audio Firewire 410.

Thanks, Ade and others. I’ve convinced myself that the laptop is to blame. As it was a temporary solution anyway (work laptop), no big deal. It was (and continues to be) a pretty good exercise in tuning (well, and throwing money down a rat hole). I sprung for an RME Babyface, upgraded the laptop disks to the fastest M.2 (half terabyte) and SAS SSD (full terabyte), and twiddled a lot of system settings. I thought the bit-locker encryption wouldn’t be that big a factor, but I believe that it makes it a non-starter for live use. I’ll use the laptop at practice, it’s good enough for that.

I have a Komplete Audio 6 and a PreSonus AudioBox I tried also. KA6 is about the same as the Babyface, and PreSonus is a BSoD generator. The PreSonus seems to work fine on the Cubase home studio.

Trying all different combinations, I haven’t been able to get the buffer size below 1024, and 2048 is very reliable with the Babyface. If I can run that with buffers below 1024, I’m pretty happy. Most of my keys work is organ and they latency doesn’t bother me that much. But playing sax through it is a little difficult–I keep playing too far behind the beat with that latency delay in my ears. I’m going to switch my monitoring to ASIO direct and forgo effects for my in-ears (maybe some reverb from the Babyface).

My main rig has a purpose-built fast rackmount computer with SSDs and plenty of memory. Together with my Sapphire Pro40, my buffer size can go down to 128 and work (almost) flawlessly. My rack is pretty heavy, though. (Of course it’s no different than lugging a Fender Twin to a gig.)


1 Like

Hmm. that sounds like your system configuration isn’t really up to real-time music. I’ve looked up the proc of your EliteBook - haven’t had any experience with AMD processors in recent years, but it’s supposed to be on par with an energy-saving Intel i3 (but with 4 cores instead of just 2 for the Intel). So. with a CPU frequency of 2.7 to 3.6 GHz, it should definitely be able to run lower than 1024 samples.

Have you tried all of @brad’s power settings from the “Glitch Free” book? Most laptops (especially the corporate ones) are pre-set for quiet, energy efficient running, which involves significant processor throttling.

I run a Babyface on my live laptops (both Intel i7 quad-cores) and I have no issues with a buffer at 128 samples - 1024 would feel awfully sluggish to me.



I had a Komplete Audio 6 as my backup interface for some time. Whilst it will allow you to drive down buffer sizes to a similar level as the Babyface, its driver architecture doesn’t seem to be as efficient as RME’s - don’t get down to the same level of responsiveness as the Babyface.

I also tested the PreSonus AudioBox as a cheap alternative, but the latencies I was able to achieve with it weren’t anything worth writing home about - back it went to the big T.



1 Like

@Torsten I definitely went through @Brad’s glitch book and did a lot of tweaking. I turned off all the “green power” settings. But, I really think it’s Bit Locker preventing me from getting the best responses. I tried a MOTU 4Pre (the one with 4 XLR inputs) and that was the worst of all and it went back to from whence it came.

BTW, my rack mount computer is AMD as are both of my studio computers. They work flawlessly. All the same, next big build I do will probably be with Intel.

Checking with LatencyMon, it will run fine (all green) for about 4-5 minutes, then something happens and it turns red and gets upset. I was wondering if the Win10 patches for Spectre and Meltdown weren’t causing problems. Since the Intel firmware was recalled, I think that’s a big question. I haven’t seen AMDs patches. I have installed all the HP ServicePaqs and updated the BIOS. I disabled the internal audio and everything else in Device Manger I wasn’t using.