My racks don't apply to keyboard transpose

Seems that I need to general transpose for racks, nor does keyrange work?
To be clear: only the transpose after Tr: off works, the other ways don’t.

Are you saying that the transpose options in the rack’s MIDI input route don’t seem to have an effect? They definitely should. Are you sure you’re not using actual device MIDI port inputs inside the rack, instead of using Rack MIDI In? If the rack internally connects to device MIDI port inputs, it’ll be ignoring whatever you’re passing into the rack via the transposed route.


indeed, only working on the last setting.
I’ll make a video of it…

Lower your sound :slight_smile:
Seems that it only applies to the Live transpose here?
@brad I probably already adressed this.

I now notice that the revert isn’t implemented also.
So when I edit this song, select an other song, choose NO to save, and get back to the first, all the settings are still altered even after not saving.
Restarting c3 helps.

You haven’t showed us inside the rack you’re playing the sound on…

Ow, this works of course :slight_smile:
But keyrange and transpose not.

Just show me a screenshot of the inside of your rack and I’ll show you what I think is wrong

Thx Neil

Right - so the routes at the top of your rack are coming from SAMSON keyboard, not from Rack MIDI In. So the sound is playing directly from your keyboard, and not from the route you’re applying the transpose to.

Change those routes to use Rack MIDI In, and it’ll magically work :stuck_out_tongue:

Btw I’m so in love with my V(irtual) Guitars simulation I made hehe :slight_smile:
The mixing guy told me he could mix it like it was a real second guitar playing along with the band :slight_smile: which is a big compliment for the keyboard :wink: Soon we don’t need guitarist anymore :wink:

OMG you’re genious !!!
Thx man !!! <3

1 Like

Then your guitarist will get a guitar synth and play all your synth parts :stuck_out_tongue:

WHOEHAHAHAHA (evil laugh :smiley: )

Your solution works great !
Are you saying I should ALWAYS use Rack midi in instead of Samson ?

Could it be that the change you’re talking about are not at the song level, but at the rack level, and you’ve saved the rack? Then when you discarded changes to the song, the change you made is still saved because they’re actually in the rack? I suspect that’s what you’re doing.


Not always, but usually. Generally, you want the rack to play whatever you route to it in your song, so then you use Rack MIDI In. That then means the song can control the rack with splits, transpose, velocity curves etc. I think I probably use Rack MIDI In in all of my racks.

If you use Samson Keyboard in your rack instead, it’ll ignore what your song is set to do (transpose, splits etc) and just play what the keyboard is doing. That’s usually not what you want.


1 Like

Good thinking :slight_smile:
But no, it’s in the song, not the rack.

Regarding discarding song changes, I do it all the time, and it works perfectly for me. I’d suggest keeping a look out for it happening again, and see exactly what’s happening (particularly with regard to when you save racks and save songs, and where the changes actually are).


1 Like

Could it possibly be not merely in the song, but in the state? If you have states set to save automatically when you change them, that might be what is doing this. Un-check “Edit ==>Automatically Update States” perhaps? (And use CTRL-U to manually update them instead…)



Just to clarify this.

Every MIDI route has a setting “Ignore Global Transpose Setting”

Originally this was designed for rhythmic instruments where you don’t want the drum hits transposed however it’s also important to make sure you don’t “double transpose” something when it goes through two routes. eg: 1. routing to a rack and 2. route from rack input to an instrument.

So, when routing from an environment MIDI in port (eg: Main Keyboard) this option is turned off by default (ie: it will transpose). When creating routes from other plugins, or from a Rack MIDI In port, it’s turned on (ie: transpose disabled).

@So_Godly - any change you originally created a route in the rack connected to an environment input port - and then changed it to a rack MIDI in port and didn’t turn on “Ignore Global Transpose” for that route. Or vice-versa? Easy trap - I should think about how to improve that.