My Midi Filter isn't suppressing anything - please help!

I’m currently trialling the Solo version as thinking about buying, mainly for the midi binding/filtering features.

I’ve routed the midi passthrough port of a VST instrument to my output midi device and added a filter to the route to only allow some CC’s (99,98 and 6 for NPRN data). However, on inspecting the midi monitor (post filter) on the route (and on the output port) it is showing all events passing through.

The text of the filter says “Suppress notes, CCs except #99,98,6”. (If I change it to suppress ALL notes and CCs it still allows everything through). Channels set to omni.

Not sure what I’m doing wrong.

Any ideas? (Using build 3653 x64)

Can you add a screenshot of the settings - will make it a little easier to help you.

And welcome to the forum and the shiny world of Cantabile :-).

It’s okay. I routed directly from my midi controller instead and put the same filter there. And a route from my midi controller to my VST plug with the opposite filter on it. The problem seems specifcially to do with filtering the route from midi passthrough port but I don’t feel I need to worry about it now.

1 Like

Great, glad it worked out for you.