Must play note to force sound after song change

When I change songs I must play a couple of notes on my controller for the new instrument to sound. This is a pain. How can I force the sound to “completely load” after a song change?


Could you give more specifics? Thanks.

Are you using a sampler /ropmler and asking it to completely load when you change songs?
There are strategies for dealing with this, if that’s your issue.

Hi, I have just finished playing a song. I now go to the next song, which just happens to include a couple of Kontakt instruments. I must now play a few notes on my controller to “obtain” the instrument. This is a problem. How can I fix this. Thanks.

In Kontakt, could it be the “Instrument Preload Buffer Size” is too small in Kontakt’s Options/Memory page? You can keep that small if you are running off an SSD, but off a spinner that often needs to be larger. I learned that from this video.



Odd, because I’m having some instances of this with the new build and I didn’t have it before. I’m not sure but I think it’s happening on sounds other than just Kontakt. I used to have this issue with Addictive Keys- the first time you played a note it would stutter, like it was still loading the patch. Then it would be fine.

I had this issue with just a couple of the Kontakt library instruments.

Are you using racks for your songs and loading a complete set list for your show, or separate instruments for each song?

I solved the problem in my case by having a ‘blank’ song at the beginning of my set list with bindings set up that sent a note on and note off to the problematic instruments in the racks at a low velocity. this would ‘pre-charge’ the plugin so it worked when it came up in the set-list…

this is a Kontakt issue, not a Cantabile one BTW and I’m sure someone else will come up with a more proper way of dealing with it…