ModalApp VST3 crippled in C3 (but OK in Reaper)

Briefly: When the VST3 version of ModalApp (called the Modal VST3 Plugin) is loaded into C3, it does not synch well with the CraftSynth 2.0 device itself.

Changing encoders by hand on the CraftSynth hardware rarely updates the on-screen controls in the VST. The on-screen controls do seem to update most of the time when you enter the specific widget for the control with the mouse. Also, changing controls on the VST interface has weird effects on the hardware, seemingly limiting the range of action of the hardware control after a modification in the VST.

Testing the same setup in Reaper v6.21 works AOK. All physical changes on the hardware are reflected pronto in the VST interface and things in general synch up nicely.

Some details: I’ve been using ModalApp as a standalone sound design tool for my CraftSynth 2.0. Works great on a PC.

Because of MIDI / USB exclusive reasons (I think), I cannot run ModalApp while routing MIDI through Cantabile to the CraftSynth, so I need to run the VST3 version of ModalApp - the Modal VST3 Plugin - in C3.

Versions: C3.0.3694, ModalApp v2.8.0, Modal Plugin (VST3) v1.7.1, Reaper 6.21

Hi Clint,

Thanks for reporting this. I’m not familiar with this device or the plugin so I’m not sure what might be the issue here.

At first I was wondering whether the plugin communicates with the device via MIDI (and therefore through Cantabile’s MIDI routing) but on reading the docs for the plugin it looks like it uses a direct connection to the device via USB. So that pretty much eliminates Cantabile from the equation since it does nothing at the USB level and only communicates with MIDI and audio device drivers.

I’ve reached out to Modal’s support to see if they have any insight. In the meantime some things to try (complete guesses):

  • Are you using the same audio driver in Cantabile and Reaper - perhaps there’s a conflict there somewhere?
  • If using USB audio device can you make sure the audio device and the synth are on different USB ports?
  • Try switching Cantabile to use the Null Audio driver and see if the plugin works better.
  • Try fiddling with some of Cantabile audio engine threading options. Unlikely but worth the try.

Sorry I don’t have a better answer.

Brad

Thanks for addressing this, Brad.

All this was done using the RME ASIO driver v2.21.

My Babyface Pro FS was used for all testing and plugs into a different USB plug on my computer, but I’m not sure that is a different “port” (I’m hazy on exactly how USB works …).

I and my gear are now packed for an extended trip … I should have my road gear set up in Oslo in a few days (Sylphyo, laptop, Babyface, etc) and could do some of the testing you recommend …

Thanks again!

1 Like

I tested this with only the CraftSynth plugged in to the laptop’s USB ports and no hardware audio interface. I selected the Null Audio driver. The CraftSynth VST3 still fails in the same way as I reported.

I also tried changing Number of Audio Threads, Multi-processor Mode, and Thread Affinity Mode to various settings and it seemed to make no difference - the CraftSynth VST3 still fails.

Laptop is an i7-11gen 8-core 64GB with 6T of disk (all SSD).

Hi Clint,

Just got a reply from Modal. Their developer says this:

*Although we make a direct connection with the synth, we’re only using Windows’ own class compliant midi driver. There’s no audio over USB and therefore no audio drivers are involved. Next, we’ve loaded the Lite version of Cantabile and here the plugin works as expected with control settings staying in sync regardless of whether settings are changed in the plugin UI or on the device. The plugin successfully passes on tempo information, too. The only question that I have is whether the Craft Synth 2 midi DIN ports are also connected and maybe there’s a midi loop set up somewhere.?

Sounds like it’s working fine for them and it might be something about your setup that’s causing the issues.

As a test, try this:

  1. Go to Cantabile -> Options -> MIDI Ports
  2. Clear the check marks on all ports
  3. See if the plugin behaves better and stays in sync with the device.

Brad

1 Like

Here in Oslo with the CraftSynth on the window shelf (next to the Aquavit bottle) …

Results are the same (CraftSynth VST3 still exhibits lack of synchronization with changes in the physical hardware) with all MIDI ports unchecked.

I tested on both USB 2.0 and 3.2gen1 ports.

No other cables connected than the USB between PC and CraftSynth 2.0 and the laptop’s charger.

loopMIDI is not running.

I’m out of ideas for things to test …

Hi Clint,

I too have no idea what might be causing this. Perhaps get in touch with Modal’s support and see if they can help.

Brad