MIDI Port is Disconnected [SOLVED]


#1

Hi. I am having a problem on my gig PC that is driving me nuts…

My main USB interface is a Focusrite Scarlet 2i4, and up until recently Cantabile has played perfectly with it, but no more.

Both MIDIOX and Pocket MIDI both see the interface with no issues

But Cantabile does not (despite it happily using the Audio port of the same 2i4), and complains that the device is disconnected.

I’ve ran Cantabile with MIDI Logging enabled. Attached is my Log file and Settings.json

A little stranger, but I have a backup port in the rack, an old MIDISPORT 2x2. Which is suddenly not working until I hot a note and then get some aftertouch flowing and then release the note, then it all starts working. That is true in both MIDIOX and PocketMIDI as well, so not unique to Cantabile! I thought I’d mention it in case others have had similar issues and know what to do! That is a very old device mind. I’ve had it since 2001, so maybe it is time to upgrade it.

Diagnostics.zip (196.8 KB)


#2

Hey @Derek

it looks like your Scarlet has changed its name - your MIDI-OX calls it “Focusrite USB MIDI”, instead of “Scarlett 2i4 USB” as shown in your Cantabile settings. Maybe a new driver? or some other Windows installation madness?

Can you check if there is now a “Focusrite USB MIDI” entry in your Cantabile MIDI input ports - if it’s there, this should now work instead of the “Scarlett 2i4” entry…

Once you’ve got it working, you can either delete the “stranded” Scarlett port - or keep it in case it should change its name again…

Cheers,

Torsten


#3

Hi, Torsten.

Sometimes when you are bogged down in an issue, when you can’t see the wood for the trees, you can miss the blindingly obvious, and need somebody to point it out!!. :slight_smile:

I hope that this is one of those… will check first thing tomorrow and report back…


#4

Hi, Torsten

You were 100% bang on correct, and I feel such a chump! :flushed:

When I did the last round of driver and OS updates, it does indeed look like the device name changed. Select the right port and it all works…

Thanks for pointing out the blindingly obvious! :smiley: