MIDI-only Operation?

Running Cantabile with only a MIDI interface (and no audio interface) does not seem to work.

Tried running Cantabile with just a MIDISport 2x2 connected via direct USB. Also tried with a Sylphyo Link box connected. The MIDI ports are recognized in Cantabile as being connected, but no MIDI passes through. I tested the Sylphyo Link box with another app (Sylphyo Bench) and the port operates normally.

When I add my audio interface (RME UCX II) on a separate direct USB and re-start Cantabile, the Sylphyo Link and MIDISport MIDI ports work as expected.

Powering down the audio interface while Cantabile is up has similar results - the MIDI stream on the (separate, unrelated) MIDI devices stops.

Bug? Feature? (… or maybe my SNAFU …)

Have you tried selecting ‘null’ as the audio interface? If you don’t have an audio interface selected, then the audio engine can’t start, and then the midi signals does not get handled either.

2 Likes

That works. Thanks @TorstenH!

MIDI passes reliably on all channels with the Null Audio driver selected.

Interesting that Null Audio has a buffer, with 64 samples as a minimum - more than the RME UCX II and BabyFace Pro-FS, which have a minimum of 48 samples @ 48 kHz.

1 Like

Don’t forget to switch back when getting “back to normal” - I’m still hoping for Brad to include support for a default sound card and having the null as standard backup solution :-).

If you look in settings.json for ‘audioDriverSettings’, you’ll be able to set the bufferSize for the null interface manually.
You’ll have to do some of your excellent testing to see if it makes a difference :slight_smile:

1 Like