Metronome Tempo doesn't pass between states?

I have several states set up in a song, each with unique samples which get triggered on state load. In bindings, I have one pedal set to Tap Tempo, and all of the media players have tempo bound to media player speed. This is so I can keep the tempo in sync with our live band. This works well within a state, but when I change states, the adjusted tempo doesn’t pass from one state to the next-- as a result, each state now has their own slightly different tempo, and I have to adjust the tempo after the next state/sample starts. Once I adjust the tempo in State 1, I want that new adjusted tempo to continue into State 2. Surely that’s an option somewhere?

Hi Jeff,

There’s a checkbox in the Song State Behaviors Box You need to turn off. You get there by clicking any part of the metronome with the States Behavior Panel open and uncheck the offending box.



Huzzah! Thanks @dave_dore!

EDIT: My mistake-- I had not fully wrapped my head around sync status and didn’t have them set to Slave (Musical). All are now tempo controlled!

Well, I thought that had it, but now it appears I have another tempo problem: some of the MIDI files being played back are not syncing to the tempo. The metronome is displaying the correct tempo (and is adjusting with tap tempo), but some files are playing consistently slow. If I put on an external metronome and set it to the same tempo as C3, it’s obvious that they’re not on the same beat.

Just to detail up front:
–All media players have metronome tempo bound to the MP speed,
–I have tried the same Media Player with State Behavior-> Playback Speed both on and off, and
–They’re all on Sync Mode (None)