Melda crashing woes


i’ve been trying out the Melda demos and find that they are crashing all the time in Cantabile.
both the vst2 and 3 can be made to lock up/crash the gui.
i’m using the latest C3, the Melda 15.0 demos, win10, C3 opengl enabled or disabled.
to crash:
open a Melda plugin gui.
play with it a bit
press the tab key

it’s not crashing in a way that produces a report in C3

Melda just released 15.01, so maybe there was something flaky with 15.0? I’d download and install the latest.

just tried, same story.
i’ve contacted Melda. C3 wasn’t in their long list of vst hosts on the contact form :frowning:
maybe soon it will be :slight_smile:

I played Melda’s MSoundFactory 15.01 in C3 Build 3696 on Tuesday with no issues.

I’ve looked into this and it’s actually a bug in Windows related to tab key handling. I’ve put a workaround into Cantabile that will be in the next build.

In the meantime, try to avoid pressing the Tab key.


hi Brad,
that’s awesome, thank you.

i don’t know why i was using the tab key for sure.
i think i was trying to find a way to negotiate the Melda ui.

hi @brad,

i was running a slightly older version of C3.
i haven’t run into the problems with 3696 (which pre-dates the fixes you added above)

it’s not just TAB keys within Melda plugins that cause a gui lock up.
it seems that Ctrl and others too.

your programming talents are deeply respected here, but please amend the title of this thread because Melda plugins are simply not editable in Cantabile at this time.

Hi Neil, I use Melda plugins (paid versions) all the time in C3 and do not have issues with the combination. That said, I always mouse everything that I edit that isn’t typed in ascii characters. And no problems with Ctrl, Shft, Alt + mouse or mouse button actions.

Hi Sekim,
Thanks for helping. i’m finding only short gui lockups with build 3696 so far.
I’m having big issues with MSoundFactory though, in particular the Monastery Grand.
If you have that plugin and patch, could you try the following?
Enable all the harmony options.
Look at the generator page where the samples are laid out.
Click on one of the mic positions on the modular grid on the left. I tried A.
You should see the selected samples change as you hit notes.
If you carry on playing for a while it should start misbehaving, with notes sounding again after a delay and getting choked up.
I’ve tried this in Reaper but don’t get the same problem.
After a while C3 sometimes crashes.

I do have a fix for this but I need to get a new build out. I’ll see if I can get it done in the next couple of days.

I don’t have any of their VSTi but it looks like Brad has you covered in a few days!

To be honest, now I’m using the lastest experimental build instead of the latest stable it’s a world better.

Workaround for Tab key issue is available now in build 3697.

Thanks Brad!
I’ll check it out over the weekend.